Skip to content

← Actionable
Critical, CVSS 10.0amended

Decepticon: Role-boundary forgery via ChatML special-token literals in web crawl output composed into LLM context

CVE-2026-61732GHSA-g5f9-3xfg-p9mf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (decepticon-core 1.1.17; decepticon-sdk 1.1.17; decepticon 1.1.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-61732: 1.47% estimated exploitation activity in the next 30 days; percentile 73.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Decepticon wraps web crawl results — the output of agent reconnaissance against target services — into LLM messages without neutralizing ChatML special-token literals. Under the BYOK (Bring Your Own Key) deployment model, users configure their own LLM credentials to any OpenAI-compatible endpoint. Most open-source and self-deployed model providers (vLLM, SGLang, Ollama, LM Studio, text-generation-webui, etc.) do not filter special-token literals from user content in their default configurations. Those literals are parsed into structural role-boundary token IDs, meaning an attacker string planted in a target web page forges a new operator turn the model treats as authoritative, bypassing Decepticon's agent guardrails and resulting in arbitrary command execution inside the Kali Linux sandbox. The vast majority of open-source and self-deployed model providers do not filter special-token literals. vLLM explicitly declined to fix this issue on 2026-04-21, closing it as "out of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g5f9-3xfg-p9mf

  2. Revision 2 · amended ·

    Amended from osv record GHSA-g5f9-3xfg-p9mf

  3. Revision 1 · created ·

    Published from ghsa record GHSA-g5f9-3xfg-p9mf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61732

Advisory: Decepticon: Role-boundary forgery via ChatML special-token literals in web crawl output composed into LLM context
IDs: CVE-2026-61732, GHSA-g5f9-3xfg-p9mf
Record: https://patchnext.com/advisories/cve-2026-61732 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: decepticon-core 1.1.17; decepticon-sdk 1.1.17; decepticon 1.1.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI decepticon-core: affected <= 1.1.16; fixed in 1.1.17
- PyPI decepticon-sdk: affected <= 1.1.16; fixed in 1.1.17
- PyPI decepticon: affected <= 1.1.16; fixed in 1.1.17

## Suggested inspection (read-only)
- `python -m pip show decepticon-core`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show decepticon-sdk`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show decepticon`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on decepticon-core, decepticon-sdk, decepticon.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g5f9-3xfg-p9mf (GitHub-reviewed advisory GHSA-g5f9-3xfg-p9mf lists affected ranges: PyPI decepticon-core >=0 =0 =0 <=1.1.16)
- Verified: https://osv.dev/vulnerability/GHSA-g5f9-3xfg-p9mf (OSV record GHSA-g5f9-3xfg-p9mf lists affected ranges: PyPI decepticon-core >=0 =0 =0 <1.1.17 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…