Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenFGA: ListUsers returns a deliberately-excluded user when a but not exclusion under a type-bound wildcard is intersected (and) with another relation that also grants that user

CVE-2026-61709GHSA-g3pg-frfm-pr2m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openfga/openfga 1.18.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-61709: 0.35% estimated exploitation activity in the next 30 days; percentile 28.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description In OpenFGA, the ListUsers API could incorrectly return a user who should have been excluded. Preconditions This applies if all of the following are present: - The authorization model contains a relation defined as an intersection (and) where at least one operand is an exclusion of the form base but not excluded: e.g. rel1: (publicuser but not blocked) and rel2 - The base side of that exclusion is granted through a type-bound public wildcard (e.g. user:). - A user excluded by the but not clause is also granted, via a concrete tuple, through another operand of the intersection. - Your application uses ListUsers to enumerate or enforce access Fix Upgrade to OpenFGA v1.18.1 or greater. Acknowledgements OpenFGA would like to thank @5ud0er for the detailed report.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g3pg-frfm-pr2m

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6488

  3. Revision 1 · created ·

    Published from osv record GHSA-g3pg-frfm-pr2m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61709

Advisory: OpenFGA: ListUsers returns a deliberately-excluded user when a `but not` exclusion under a type-bound wildcard is intersected (`and`) with another relation that also grants that user
IDs: CVE-2026-61709, GHSA-g3pg-frfm-pr2m
Record: https://patchnext.com/advisories/cve-2026-61709 (revision 3, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/openfga/openfga 1.18.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/openfga/openfga: affected <= 1.18.0; fixed in 1.18.1

## Suggested inspection (read-only)
- Go github.com/openfga/openfga: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/openfga/openfga.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g3pg-frfm-pr2m (OSV record GHSA-g3pg-frfm-pr2m lists affected ranges: Go github.com/openfga/openfga >=0 <1.18.1 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6488 (OSV record GO-2026-6488 lists affected ranges: Go github.com/openfga/openfga >=0 <1.18.1 (fixed))
- Verified: https://github.com/advisories/GHSA-g3pg-frfm-pr2m (GitHub-reviewed advisory GHSA-g3pg-frfm-pr2m lists affected ranges: Go github.com/openfga/openfga >=0 <=1.18.0)

Commands are suggestions: review each one before running it.

Loading voting…