Skip to content

← Actionable
High, CVSS 7.5amended

ReactPress has SQL injection via dynamic column names in TypeORM query builders

CVE-2026-61685GHSA-wmw4-mw6x-6vfm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fecommunity/reactpress 3.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-61685: 0.53% estimated exploitation activity in the next 30 days; percentile 45.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary ReactPress API list endpoints build TypeORM QueryBuilder conditions using unsanitized HTTP query parameter names as SQL column identifiers (e.g. article.${key} ). TypeORM parameterizes values but not column names, allowing unauthenticated attackers to inject SQL through crafted query string keys. Impact An unauthenticated remote attacker can perform blind SQL injection against the application database, potentially exfiltrating sensitive data (users, settings, API keys, article content, etc.). Affected endpoints (unauthenticated GET) - GET /api/article - GET /api/comment - GET /api/file - GET /api/page - GET /api/Knowledge Affected code Vulnerable pattern in findAll() methods, including but not limited to: - server/src/modules/article/article.service.ts - server/src/modules/comment/comment.service.ts - server/src/modules/file/file.service.ts - server/src/modules/page/page.service.ts - server/src/modules/knowledge/knowledge.service.ts Remediation - Whitelist allowed filter…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wmw4-mw6x-6vfm

  2. Revision 2 · amended ·

    Amended from osv record GHSA-wmw4-mw6x-6vfm

  3. Revision 1 · created ·

    Published from ghsa record GHSA-wmw4-mw6x-6vfm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61685

Advisory: ReactPress has SQL injection via dynamic column names in TypeORM query builders
IDs: CVE-2026-61685, GHSA-wmw4-mw6x-6vfm
Record: https://patchnext.com/advisories/cve-2026-61685 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fecommunity/reactpress 3.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fecommunity/reactpress: affected <= 3.6.0; fixed in 3.7.0

## Suggested inspection (read-only)
- `npm ls @fecommunity/reactpress --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fecommunity/reactpress.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wmw4-mw6x-6vfm (GitHub-reviewed advisory GHSA-wmw4-mw6x-6vfm lists affected ranges: npm @fecommunity/reactpress >=0 <=3.6.0)
- Verified: https://osv.dev/vulnerability/GHSA-wmw4-mw6x-6vfm (OSV record GHSA-wmw4-mw6x-6vfm lists affected ranges: npm @fecommunity/reactpress >=0 <3.7.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…