Skip to content

← Actionable
High, CVSS 8.1amended

DIRAC: Pilot code downloaded over unverified HTTPS connection

CVE-2026-61668GHSA-vg99-gr89-qhw9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dirac 9.1.10, 9.0.22, 8.0.79), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dirac

    Affected
    >= 6.20.1, < 8.0.79>= 8.1.0a1, < 9.0.22>= 9.1.0, < 9.1.10
    Fixed in
    9.1.10, 8.0.79, 9.0.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-61668: 0.40% estimated exploitation activity in the next 30 days; percentile 33.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The second stage pilot (pilot.tar) is downloaded by the initial wrapper script without any verification of the webservers' SSL certificate and the contained script is subsequently executed. The checksum is tested, but the reference checksum file is downloaded over the same unvalidated channel. Details The pilot wrapper downloads and executes the main second stage pilot script, but the SSL validation on this connection is explicitly disabled (to match old python < 2.7.9 behaviour): https://github.com/DIRACGrid/DIRAC/blob/integration/src/DIRAC/WorkloadManagementSystem/Utilities/PilotWrapper.py#L292-L296 This means that the second stage pilot code is not verified in any way and could potentially be altered by a man-in-the-middle attack to execute arbitrary code in the pilot context (i.e. with access to the pilot proxy/credentials). The HTTPS connection should be validated against both the system certificates and $X509CERTDIR and fail if neither validate correctly. Impact This…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vg99-gr89-qhw9

  2. Revision 1 · created ·

    Published from osv record GHSA-vg99-gr89-qhw9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61668

Advisory: DIRAC: Pilot code downloaded over unverified HTTPS connection
IDs: CVE-2026-61668, GHSA-vg99-gr89-qhw9
Record: https://patchnext.com/advisories/cve-2026-61668 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dirac 9.1.10, 9.0.22, 8.0.79. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dirac: affected >= 6.20.1, < 8.0.79; >= 8.1.0a1, < 9.0.22; >= 9.1.0, < 9.1.10; fixed in 9.1.10, 8.0.79, 9.0.22

## Suggested inspection (read-only)
- `python -m pip show dirac`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dirac.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vg99-gr89-qhw9 (OSV record GHSA-vg99-gr89-qhw9 lists affected ranges: PyPI dirac >=6.20.1 =8.1.0a1 =9.1.0 <9.1.10 (fixed))
- Verified: https://github.com/advisories/GHSA-vg99-gr89-qhw9 (GitHub-reviewed advisory GHSA-vg99-gr89-qhw9 lists affected ranges: PyPI dirac >=6.20.1 =8.1.0a1 =9.1.0 <9.1.10)

Commands are suggestions: review each one before running it.

Loading voting…