websocket-driver-ruby: Denial of service via malformed Host header
CVE-2026-61666GHSA-2x63-gw47-w4mm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (websocket-driver 0.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems websocket-driver
- Affected
- < 0.8.2
- Fixed in
- 0.8.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2x63-gw47-w4mm lists affected ranges: RubyGems websocket-driver >=0 <0.8.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2x63-gw47-w4mm lists affected ranges: RubyGems websocket-driver >=0 <0.8.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H · score source
- EPSS
- CVE-2026-61666: 0.45% estimated exploitation activity in the next 30 days; percentile 38.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If this library is used to implement a WebSocket server on top of a TCP server, by using the `WebSocket::Driver.server()` method, then a client can cause the server to crash by sending a `Host` header that is not a valid `host[:port]` string. When this happens, a `URI::InvalidURIError` exception is raised which is not caught, and this can cause the server process to crash if the application does not catch the error from the `parse()` method itself.
Patches The issue has been patched in version 0.8.2 by making the request parser catch `URI::InvalidURIError` and enter an error state if the `Host` header is malformed. This means the request is considered invalid and should not establish a WebSocket connection.
Workarounds No known workarounds exist.
Acknowledgements This issue was discovered and reported by Pranjali Thakur, DepthFirst Security Research Team.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-2x63-gw47-w4mm
- Revision 2 · amended ·
Amended from ghsa record GHSA-2x63-gw47-w4mm
- Revision 1 · created ·
Published from ghsa record GHSA-2x63-gw47-w4mm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-61666 Advisory: websocket-driver-ruby: Denial of service via malformed Host header IDs: CVE-2026-61666, GHSA-2x63-gw47-w4mm Record: https://patchnext.com/advisories/cve-2026-61666 (revision 3, source checked 3 Nov 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: websocket-driver 0.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems websocket-driver: affected < 0.8.2; fixed in 0.8.2 ## Suggested inspection (read-only) - RubyGems websocket-driver: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on websocket-driver. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2x63-gw47-w4mm (GitHub-reviewed advisory GHSA-2x63-gw47-w4mm lists affected ranges: RubyGems websocket-driver >=0 <0.8.2) - Verified: https://osv.dev/vulnerability/GHSA-2x63-gw47-w4mm (OSV record GHSA-2x63-gw47-w4mm lists affected ranges: RubyGems websocket-driver >=0 <0.8.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…