Pterodactyl's shared global rate-limit key on login and 2FA checkpoint enables unauthenticated panel-wide authentication lockout (DoS)
CVE-2026-61609GHSA-xvc3-826v-xf47
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pterodactyl/panel 1.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pterodactyl/panel
- Affected
- >= 1.7.0, <= 1.12.4
- Fixed in
- 1.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xvc3-826v-xf47 lists affected ranges: Packagist pterodactyl/panel >=1.7.0 <1.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xvc3-826v-xf47 lists affected ranges: Packagist pterodactyl/panel >=1.7.0 <=1.12.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-61609: 0.50% estimated exploitation activity in the next 30 days; percentile 42.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The authentication rate limiter used for the login and two-factor checkpoint endpoints applies a single global bucket shared by every client, instead of keying per IP or per account. An unauthenticated attacker sending ~10 requests per minute from one IP exhausts the shared bucket and causes HTTP 429 for every user on every IP attempting to log in or complete 2FA, for as long as the attack is sustained. This is a trivially triggered, unauthenticated, panel-wide authentication denial of service. Details In app/Providers/RouteServiceProvider::configureRateLimiting() the limiter is defined as: The forgot-password branch is correctly scoped with -by($request-ip()). The fall-through return, which covers POST /auth/login and POST /auth/login/checkpoint (see routes/auth.php, the throttle:authentication group), omits -by() entirely. For a named limiter, Laravel 11 derives the cache key as md5($limiterName . $limit-key)…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xvc3-826v-xf47
- Revision 1 · created ·
Published from osv record GHSA-xvc3-826v-xf47
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-61609 Advisory: Pterodactyl's shared global rate-limit key on login and 2FA checkpoint enables unauthenticated panel-wide authentication lockout (DoS) IDs: CVE-2026-61609, GHSA-xvc3-826v-xf47 Record: https://patchnext.com/advisories/cve-2026-61609 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pterodactyl/panel 1.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pterodactyl/panel: affected >= 1.7.0, <= 1.12.4; fixed in 1.13.0 ## Suggested inspection (read-only) - Packagist pterodactyl/panel: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pterodactyl/panel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xvc3-826v-xf47 (OSV record GHSA-xvc3-826v-xf47 lists affected ranges: Packagist pterodactyl/panel >=1.7.0 <1.13.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xvc3-826v-xf47 (GitHub-reviewed advisory GHSA-xvc3-826v-xf47 lists affected ranges: Packagist pterodactyl/panel >=1.7.0 <=1.12.4) Commands are suggestions: review each one before running it.
Loading voting…