Skip to content

← Actionable
Medium, CVSS 5.1amended

djust is vulnerable to stored/reflected XSS via javascript: URLs in built-in component template tags

CVE-2026-61597GHSA-4mf4-73j6-mvrw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (djust 1.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI djust

    Affected
    < 1.0.7
    Fixed in
    1.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-61597: 0.41% estimated exploitation activity in the next 30 days; percentile 35.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Many djust built-in component template tags (djust.components.templatetags.) render a developer/user-supplied URL into an href / action attribute, HTML-escaping it with conditionalescape but never validating the URL scheme. HTML escaping prevents attribute breakout but does not neutralize a javascript: URI (which needs no escapable characters), so a URL value of javascript:alert(document.cookie) lands verbatim in <a href="javascript:alert(document.cookie)" and executes in the victim's session on click. Affected sinks (executing href/action contexts; not exhaustive): breadcrumb (djustcomponents.py:1535; advanced.py:1999,2022), djnav link/dropdown/brand (djustcomponents.py:5632,5779,5807,5830), citation URL (:6936), cookie-consent privacy link (:8240), error-page action (advanced.py:1728), form action (forms.py:1239). <img src sinks are lower risk (javascript: does not execute via img src). No scheme validation exists anywhere in the component tags; a docstring at…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-4mf4-73j6-mvrw

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-4mf4-73j6-mvrw

  4. Revision 1 · created ·

    Published from ghsa record GHSA-4mf4-73j6-mvrw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61597

Advisory: djust is vulnerable to stored/reflected XSS via javascript: URLs in built-in component template tags
IDs: CVE-2026-61597, GHSA-4mf4-73j6-mvrw
Record: https://patchnext.com/advisories/cve-2026-61597 (revision 4, source checked 26 Oct 2026, 13:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: djust 1.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI djust: affected < 1.0.7; fixed in 1.0.7

## Suggested inspection (read-only)
- `python -m pip show djust`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on djust.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4mf4-73j6-mvrw (GitHub-reviewed advisory GHSA-4mf4-73j6-mvrw lists affected ranges: PyPI djust >=0 <1.0.7)
- Verified: https://osv.dev/vulnerability/GHSA-4mf4-73j6-mvrw (OSV record GHSA-4mf4-73j6-mvrw lists affected ranges: PyPI djust >=0 <1.0.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…