Skip to content

← Actionable
Critical, CVSS 9.1amended

djust has an authorization bypass on the WebSocket/SSE mount path

CVE-2026-61594GHSA-xhhm-f6hp-2qwj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (djust 1.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI djust

    Affected
    < 1.0.7
    Fixed in
    1.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-61594: 0.48% estimated exploitation activity in the next 30 days; percentile 41.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The live (WebSocket) transport authorizes a mount via checkviewauth, not Django's View.dispatch() chain. As a result, standard Django authorization — LoginRequiredMixin, PermissionRequiredMixin, UserPassesTestMixin, @methoddecorator(loginrequired, name="dispatch"), and custom dispatch() guards — and the djust admin extension's staff gate (applied only in the HTTP asview wrapper) were enforced on the initial HTTP GET but silently bypassed over WebSocket, where all events and state flow. An anonymous or under-privileged client could open a WebSocket and mount such a view — including admin list/create/change/delete — and dispatch its handlers. Patches Fixed in djust 1.0.7. checkviewauth now honors the Django AccessMixin family on every transport; a new system check S004 fails loud at startup on auth patterns the runtime cannot safely replay (decorator/overridden-dispatch forms); and the admin base mixin declares loginrequired = True + an active-staff checkpermissions gate.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xhhm-f6hp-2qwj

  2. Revision 2 · amended ·

    Amended from osv record GHSA-xhhm-f6hp-2qwj

  3. Revision 1 · created ·

    Published from ghsa record GHSA-xhhm-f6hp-2qwj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61594

Advisory: djust has an authorization bypass on the WebSocket/SSE mount path
IDs: CVE-2026-61594, GHSA-xhhm-f6hp-2qwj
Record: https://patchnext.com/advisories/cve-2026-61594 (revision 3, source checked 26 Oct 2026, 13:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: djust 1.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI djust: affected < 1.0.7; fixed in 1.0.7

## Suggested inspection (read-only)
- `python -m pip show djust`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on djust.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xhhm-f6hp-2qwj (GitHub-reviewed advisory GHSA-xhhm-f6hp-2qwj lists affected ranges: PyPI djust >=0 <1.0.7)
- Verified: https://osv.dev/vulnerability/GHSA-xhhm-f6hp-2qwj (OSV record GHSA-xhhm-f6hp-2qwj lists affected ranges: PyPI djust >=0 <1.0.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…