Skip to content

← Actionable
High, CVSS 7.5amended

MPXJ: XXE Vulnerability in MerlinReader

CVE-2026-61570GHSA-5vvx-3h34-f3gj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mpxj.net 16.4.1; net.sf.mpxj 16.4.1; mpxj 16.4.1; net.sf.mpxj:mpxj 16.4.1; net.sf.mpxj-for-vb 16.4.1; 2 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-61570: 0.47% estimated exploitation activity in the next 30 days; percentile 41.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact MPXJ used the default configuration when creating a DocumentBuilder instance, which leaves doctype declarations enabled, when parsing the XML content of the ZTIMEINTERVALS column from a Merlin project SQLite file. This would allow a carefully crafted XML payload to read an arbitrary file. However, although an arbitrary file can be read, the way the resulting parsed XML is processed by MPXJ means that the data it contains is unlikely to be available for exfiltration. Patches The patch is included in MPXJ 16.4.1 Workarounds Potential workarounds include: Avoid reading Merlin project files with MPXJ Only accept Merlin project files from trusted sources Preprocess Merlin SQLite databases to strip doctype declarations from the ZTIMEINTERVALS column

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5vvx-3h34-f3gj

  2. Revision 2 · amended ·

    Amended from osv record GHSA-5vvx-3h34-f3gj

  3. Revision 1 · created ·

    Published from ghsa record GHSA-5vvx-3h34-f3gj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61570

Advisory: MPXJ: XXE Vulnerability in MerlinReader
IDs: CVE-2026-61570, GHSA-5vvx-3h34-f3gj
Record: https://patchnext.com/advisories/cve-2026-61570 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mpxj.net 16.4.1; net.sf.mpxj 16.4.1; mpxj 16.4.1; net.sf.mpxj:mpxj 16.4.1; net.sf.mpxj-for-vb 16.4.1; mpxj 16.4.1; net.sf.mpxj-for-csharp 16.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet mpxj.net: affected >= 5.5.5, < 16.4.1; fixed in 16.4.1
- NuGet net.sf.mpxj: affected >= 5.5.5, < 16.4.1; fixed in 16.4.1
- RubyGems mpxj: affected >= 5.5.5, < 16.4.1; fixed in 16.4.1
- Maven net.sf.mpxj:mpxj: affected >= 5.5.5, < 16.4.1; fixed in 16.4.1
- NuGet net.sf.mpxj-for-vb: affected >= 5.5.5, < 16.4.1; fixed in 16.4.1
- PyPI mpxj: affected >= 5.5.5, < 16.4.1; fixed in 16.4.1
- NuGet net.sf.mpxj-for-csharp: affected >= 5.5.5, < 16.4.1; fixed in 16.4.1

## Suggested inspection (read-only)
- NuGet mpxj.net: check the installed version with your package manager.
- NuGet net.sf.mpxj: check the installed version with your package manager.
- RubyGems mpxj: check the installed version with your package manager.
- Maven net.sf.mpxj:mpxj: check the installed version with your package manager.
- NuGet net.sf.mpxj-for-vb: check the installed version with your package manager.
- `python -m pip show mpxj`: prints the installed version. Run with the environment that serves production active.
- NuGet net.sf.mpxj-for-csharp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mpxj.net, net.sf.mpxj, mpxj, net.sf.mpxj:mpxj, net.sf.mpxj-for-vb, net.sf.mpxj-for-csharp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5vvx-3h34-f3gj (GitHub-reviewed advisory GHSA-5vvx-3h34-f3gj lists affected ranges: PyPI mpxj >=5.5.5 <16.4.1)
- Verified: https://osv.dev/vulnerability/GHSA-5vvx-3h34-f3gj (OSV record GHSA-5vvx-3h34-f3gj lists affected ranges: Maven net.sf.mpxj:mpxj >=5.5.5 =5.5.5 =5.5.5 =5.5.5 =5.5.5 =5.5.5 =5.5.5 <16.4.1 (fixed))
- Verified: https://github.com/advisories/GHSA-5vvx-3h34-f3gj (GitHub-reviewed advisory GHSA-5vvx-3h34-f3gj lists affected ranges: Maven net.sf.mpxj:mpxj >=5.5.5 =5.5.5 =5.5.5 =5.5.5 =5.5.5 =5.5.5 =5.5.5 <16.4.1)

Commands are suggestions: review each one before running it.

Loading voting…