Skip to content

← Actionable
Critical, CVSS 9.8amended

@zereight/mcp-gitlab: Unauthenticated arbitrary file read via upload_markdown enables PAT exfiltration and full account takeover

CVE-2026-61560GHSA-cv3r-c5h8-f4g5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@zereight/mcp-gitlab 2.1.27), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-61560: 2.90% estimated exploitation activity in the next 30 days; percentile 86.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The SSE transport mode (SSE=true) exposes all MCP tools without any authentication. The uploadmarkdown tool reads arbitrary files from the server's local filesystem via an unsanitized filepath parameter and uploads them to a GitLab project. Combined, any unauthenticated network-reachable attacker can read /proc/self/environ to steal the server's GITLABPERSONALACCESSTOKEN and achieve full GitLab account takeover. This is the default configuration for Docker deployments. Details Two issues chain together: 1. No authentication on SSE transport (src/index.ts:7350-7388) When SSE=true (the intended mode for Docker deployments per docker-compose.yaml), the /sse and /messages endpoints have zero authentication middleware. Any HTTP client that can reach the port can establish a session and invoke all ~100+ tools using the server's configured PAT. Remote Authorization (REMOTEAUTHORIZATION=true) is explicitly incompatible with SSE mode (src/index.ts:1833-1839), so there is no way to add…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cv3r-c5h8-f4g5

  2. Revision 2 · amended ·

    Amended from osv record GHSA-cv3r-c5h8-f4g5

  3. Revision 1 · created ·

    Published from ghsa record GHSA-cv3r-c5h8-f4g5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61560

Advisory: @zereight/mcp-gitlab: Unauthenticated arbitrary file read via `upload_markdown` enables PAT exfiltration and full account takeover
IDs: CVE-2026-61560, GHSA-cv3r-c5h8-f4g5
Record: https://patchnext.com/advisories/cve-2026-61560 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @zereight/mcp-gitlab 2.1.27. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @zereight/mcp-gitlab: affected < 2.1.27; fixed in 2.1.27

## Suggested inspection (read-only)
- `npm ls @zereight/mcp-gitlab --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @zereight/mcp-gitlab.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cv3r-c5h8-f4g5 (GitHub-reviewed advisory GHSA-cv3r-c5h8-f4g5 lists affected ranges: npm @zereight/mcp-gitlab >=0 <2.1.27)
- Verified: https://osv.dev/vulnerability/GHSA-cv3r-c5h8-f4g5 (OSV record GHSA-cv3r-c5h8-f4g5 lists affected ranges: npm @zereight/mcp-gitlab >=0 <2.1.27 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…