Xinference vulnerable to remote code execution via unsafe eval() in Llama3 tool-call parsing
CVE-2026-61539GHSA-x2rj-828p-hx9m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (xinference 2.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI xinference
- Affected
- <= 2.5.0
- Fixed in
- 2.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x2rj-828p-hx9m lists affected ranges: PyPI xinference >=0 <=2.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x2rj-828p-hx9m lists affected ranges: PyPI xinference >=0 <2.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-61539: 1.23% estimated exploitation activity in the next 30 days; percentile 68.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Xinference used Python's unsafe eval() function when parsing Llama3 tool-call output generated by a large language model. Because the model output can be influenced by attacker-controlled prompts sent to the chat completion API, a remote attacker can craft prompts that cause the model to return a Python expression. Xinference then evaluates that expression on the server while post-processing the tool-call result. In the tested default deployment, authentication was not enabled, so the vulnerability was exploitable by an unauthenticated remote attacker through the /v1/chat/completions endpoint. Details Users can interact with deployed models through Xinference's OpenAI-compatible /v1/chat/completions API. The request entry point is implemented in xinference/api/restfulapi.py; non-streaming requests call the model instance's chat() method and return the inference result. When the Transformers backend is used, inference results flow through the batching logic in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-x2rj-828p-hx9m
- Revision 2 · amended ·
Amended from osv record GHSA-x2rj-828p-hx9m
- Revision 1 · created ·
Published from ghsa record GHSA-x2rj-828p-hx9m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-61539 Advisory: Xinference vulnerable to remote code execution via unsafe `eval()` in Llama3 tool-call parsing IDs: CVE-2026-61539, GHSA-x2rj-828p-hx9m Record: https://patchnext.com/advisories/cve-2026-61539 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: xinference 2.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI xinference: affected <= 2.5.0; fixed in 2.7.0 ## Suggested inspection (read-only) - `python -m pip show xinference`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on xinference. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x2rj-828p-hx9m (GitHub-reviewed advisory GHSA-x2rj-828p-hx9m lists affected ranges: PyPI xinference >=0 <=2.5.0) - Verified: https://osv.dev/vulnerability/GHSA-x2rj-828p-hx9m (OSV record GHSA-x2rj-828p-hx9m lists affected ranges: PyPI xinference >=0 <2.7.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…