mcp-server-kubernetes argument injection can expose Kubernetes cluster credentials
CVE-2026-61459GHSA-wmg3-h8mf-wgvr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-server-kubernetes 3.9.0; mcp-server-kubernetes 3.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.9.0
- Fixed in
- 3.9.0
- Affected
- < 3.9.0
- Fixed in
- 3.9.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wmg3-h8mf-wgvr lists affected ranges: PyPI mcp-server-kubernetes >=0 <3.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wmg3-h8mf-wgvr lists affected ranges: PyPI mcp-server-kubernetes >=0 <3.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wmg3-h8mf-wgvr lists affected ranges: npm mcp-server-kubernetes >=0 <3.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wmg3-h8mf-wgvr lists affected ranges: npm mcp-server-kubernetes >=0 <3.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-61459: 2.36% estimated exploitation activity in the next 30 days; percentile 83.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
MCP Server Kubernetes before 3.9.0 contains an argument injection vulnerability in structured tools (kubectl_get, kubectl_describe, kubectl_delete) that allows attackers to bypass the assertNoDangerousFlags security check by supplying resourceType and name parameters with leading dashes. Attackers can inject the --server flag to redirect kubectl commands to an attacker-controlled API server, causing the operator's bearer token to be transmitted externally and enabling full cluster compromise.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 6 · amended ·
Amended from osv record GHSA-wmg3-h8mf-wgvr
- Revision 5 · amended ·
Amended from ghsa record GHSA-wmg3-h8mf-wgvr
- Revision 4 · amended ·
Amended from ghsa record GHSA-wmg3-h8mf-wgvr
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-wmg3-h8mf-wgvr
- Revision 1 · created ·
Published from ghsa record GHSA-wmg3-h8mf-wgvr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-61459 Advisory: mcp-server-kubernetes argument injection can expose Kubernetes cluster credentials IDs: CVE-2026-61459, GHSA-wmg3-h8mf-wgvr Record: https://patchnext.com/advisories/cve-2026-61459 (revision 6, source checked 29 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mcp-server-kubernetes 3.9.0; mcp-server-kubernetes 3.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mcp-server-kubernetes: affected < 3.9.0; fixed in 3.9.0 - npm mcp-server-kubernetes: affected < 3.9.0; fixed in 3.9.0 ## Suggested inspection (read-only) - `python -m pip show mcp-server-kubernetes`: prints the installed version. Run with the environment that serves production active. - `npm ls mcp-server-kubernetes --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mcp-server-kubernetes. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wmg3-h8mf-wgvr (GitHub-reviewed advisory GHSA-wmg3-h8mf-wgvr lists affected ranges: PyPI mcp-server-kubernetes >=0 <3.9.0) - Verified: https://osv.dev/vulnerability/GHSA-wmg3-h8mf-wgvr (OSV record GHSA-wmg3-h8mf-wgvr lists affected ranges: PyPI mcp-server-kubernetes >=0 <3.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wmg3-h8mf-wgvr (GitHub-reviewed advisory GHSA-wmg3-h8mf-wgvr lists affected ranges: npm mcp-server-kubernetes >=0 <3.9.0) - Verified: https://osv.dev/vulnerability/GHSA-wmg3-h8mf-wgvr (OSV record GHSA-wmg3-h8mf-wgvr lists affected ranges: npm mcp-server-kubernetes >=0 <3.9.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…