Grav: Decompression Bomb via ZipArchiver - Missing Extraction Limits
CVE-2026-61455GHSA-928x-9mpw-8h56
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 2.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- < 2.0.1
- Fixed in
- 2.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-928x-9mpw-8h56 lists affected ranges: Packagist getgrav/grav >=0 <2.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-928x-9mpw-8h56 lists affected ranges: Packagist getgrav/grav >=0 <2.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-61455: 0.30% estimated exploitation activity in the next 30 days; percentile 22.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
- CVE-2026-61690: 0.53% estimated exploitation activity in the next 30 days; percentile 44.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary ZipArchiver::extract() lacks limits on uncompressed size, file count, and nesting depth, creating a distinct, unpatched variant of the GHSA-2vcx-h8p2-9pg9 zip bomb vulnerability. While the parallel method Installer::unZip() received comprehensive limits, ZipArchiver::extract() remains unprotected, leaving a separate code path vulnerable to the same attack vector. The vulnerability is a distinct, unpatched variant of the bug described in GHSA-2vcx-h8p2-9pg9, as it affects a separate code path in the same codebase, implementing the same abstract class. --- Details Vulnerable code - system/src/Grav/Common/Filesystem/ZipArchiver.php:29-58: What's missing vs Installer::unZip(): | Protection | Installer::unZip() | ZipArchiver::extract() | |-----------|---------------------|------------------------| | Zip Slip guard | ✅ | ✅ | | Max uncompressed size | ✅ (1 GiB) | ❌ | | Max file count | ✅ (50000) | ❌ | | Max nesting depth | ✅ (48) | ❌ | | Pre-extraction validation | ✅ All entries…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-928x-9mpw-8h56
- Revision 1 · created ·
Published from osv record GHSA-928x-9mpw-8h56
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-61455 Advisory: Grav: Decompression Bomb via ZipArchiver - Missing Extraction Limits IDs: CVE-2026-61455, GHSA-928x-9mpw-8h56 Record: https://patchnext.com/advisories/cve-2026-61455 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 2.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected < 2.0.1; fixed in 2.0.1 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-928x-9mpw-8h56 (OSV record GHSA-928x-9mpw-8h56 lists affected ranges: Packagist getgrav/grav >=0 <2.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-928x-9mpw-8h56 (GitHub-reviewed advisory GHSA-928x-9mpw-8h56 lists affected ranges: Packagist getgrav/grav >=0 <2.0.1) Commands are suggestions: review each one before running it.
Loading voting…