Grav: XSS Blueprint Validation Bypass via Twig String Concatenation
CVE-2026-61453GHSA-2c4f-86xc-cr74
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 2.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- >= 2.0.0, <= 2.0.0
- Fixed in
- 2.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2c4f-86xc-cr74 lists affected ranges: Packagist getgrav/grav >=2.0.0 <2.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2c4f-86xc-cr74 lists affected ranges: Packagist getgrav/grav >=2.0.0 <=2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-61453: 0.20% estimated exploitation activity in the next 30 days; percentile 9.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The XSS blueprint validator (Security::detectXss()) runs on the raw page content before Twig processing. An attacker can use Twig's string concatenation operator (~) to dynamically construct an event handler name at render time. The validator sees {{ "on" ~ "error" }} - a harmless Twig expression - and allows the content. After Twig processes the template, the output contains <img src=1 onerror=alert(1) which is rendered via {{ content|raw }} and executes in the victim's browser. --- Details The two-stage attack exploits the separation between validation and rendering: Stage 1 - what the XSS validator sees (raw page content): The detectXss() function scans this string. The onevents regex looks for <[^]?\s\x00-\x20\"\'\/\s= inside HTML tags. In {{ x }}, the { character is not in the boundary set [\s\x00-\x20\"\'\/], and x is not on. No match - passes validation. Stage 2 - what Twig produces (after rendering): The validator never re-inspects Twig output. The theme template…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2c4f-86xc-cr74
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2c4f-86xc-cr74
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-61453 Advisory: Grav: XSS Blueprint Validation Bypass via Twig String Concatenation IDs: CVE-2026-61453, GHSA-2c4f-86xc-cr74 Record: https://patchnext.com/advisories/cve-2026-61453 (revision 3, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 2.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected >= 2.0.0, <= 2.0.0; fixed in 2.0.1 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2c4f-86xc-cr74 (OSV record GHSA-2c4f-86xc-cr74 lists affected ranges: Packagist getgrav/grav >=2.0.0 <2.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-2c4f-86xc-cr74 (GitHub-reviewed advisory GHSA-2c4f-86xc-cr74 lists affected ranges: Packagist getgrav/grav >=2.0.0 <=2.0.0) Commands are suggestions: review each one before running it.
Loading voting…