Skip to content

← Actionable
Low, CVSS 2.1amended

Parse Server vulnerable to stored XSS via malformed Content-Type bypassing file upload extension blocklist

CVE-2026-61448GHSA-r899-h629-j84r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.10.0-alpha.2, 8.6.84), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.10.0-alpha.2< 8.6.84
    Fixed in
    9.10.0-alpha.2, 8.6.84

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-61448: 0.41% estimated exploitation activity in the next 30 days; percentile 35.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Parse Server's file upload validation uses the `fileUpload.fileExtensions` option (enabled by default with a blocklist) to reject files that browsers may render as active content, mitigating stored cross-site scripting (XSS). When an uploaded file's extension is not recognized by the `mime` package, Parse Server preserves the client-supplied `Content-Type` and passes it to the storage adapter. A malformed `Content-Type` that is not a valid `type/subtype` media type — for example `image` (no subtype), `image/` (empty subtype), or `image//svg+xml` (invalid token) — bypassed the blocklist and was stored unchanged. On storage adapters that persist and serve the uploaded `Content-Type` (such as Amazon S3, Google Cloud Storage, or Azure Blob Storage), a browser cannot parse the malformed `Content-Type` and falls back to MIME-sniffing the file content; a file whose body begins with HTML markup is then rendered as HTML, executing any embedded script in the application's origin.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-r899-h629-j84r

  2. Revision 1 · created ·

    Published from ghsa record GHSA-r899-h629-j84r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61448

Advisory: Parse Server vulnerable to stored XSS via malformed Content-Type bypassing file upload extension blocklist
IDs: CVE-2026-61448, GHSA-r899-h629-j84r
Record: https://patchnext.com/advisories/cve-2026-61448 (revision 2, source checked 30 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.10.0-alpha.2, 8.6.84. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.10.0-alpha.2; < 8.6.84; fixed in 9.10.0-alpha.2, 8.6.84

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r899-h629-j84r (GitHub-reviewed advisory GHSA-r899-h629-j84r lists affected ranges: npm parse-server >=9.0.0 =0 <=8.6.83)
- Verified: https://osv.dev/vulnerability/GHSA-r899-h629-j84r (OSV record GHSA-r899-h629-j84r lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.84 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…