Skip to content

← Actionable
Critical, CVSS 10.0amended

PraisonAI: CodeAgent Executes LLM-Generated Code Without Sandboxing and Leaks All Environment Secrets

CVE-2026-61447GHSA-2xv2-w8cq-5gxw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonaiagents 1.6.78), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-61447: 15.24% estimated exploitation activity in the next 30 days; percentile 96.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary CodeAgent.executepython() executes LLM-generated Python code in a subprocess with the complete parent-process environment (os.environ.copy()), zero AST validation, zero import restrictions, and no sandbox enforcement — even when CodeConfig(sandbox=True) is explicitly set. This allows an attacker who can influence LLM output (via prompt injection in agent input, tool results, or ingested content) to exfiltrate all environment secrets (API keys, database credentials, cloud tokens) and execute arbitrary code on the host. Details src/praisonai-agents/praisonaiagents/agent/codeagent.py (lines 253–308): Key issues: 1. Environment leak: os.environ.copy() passes every environment variable — OPENAIAPIKEY, DATABASEURL, AWS credentials, etc. to the subprocess. By contrast, the sandboxed executecode tool in pythontools.py uses env={} (empty environment). 2. No AST validation: The LLM-generated code string is written directly to a temp file and executed. No validatecodeast() call, no…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2xv2-w8cq-5gxw

  2. Revision 2 · amended ·

    Amended from osv record GHSA-2xv2-w8cq-5gxw

  3. Revision 1 · created ·

    Published from ghsa record GHSA-2xv2-w8cq-5gxw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61447

Advisory: PraisonAI: CodeAgent Executes LLM-Generated Code Without Sandboxing and Leaks All Environment Secrets
IDs: CVE-2026-61447, GHSA-2xv2-w8cq-5gxw
Record: https://patchnext.com/advisories/cve-2026-61447 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonaiagents 1.6.78. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonaiagents: affected <= 1.6.77; fixed in 1.6.78

## Suggested inspection (read-only)
- `python -m pip show praisonaiagents`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonaiagents.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2xv2-w8cq-5gxw (GitHub-reviewed advisory GHSA-2xv2-w8cq-5gxw lists affected ranges: PyPI praisonaiagents >=0 <=1.6.77)
- Verified: https://osv.dev/vulnerability/GHSA-2xv2-w8cq-5gxw (OSV record GHSA-2xv2-w8cq-5gxw lists affected ranges: PyPI praisonaiagents >=0 <1.6.78 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…