PraisonAI vulnerable to Remote Code Execution via Broken AST Sandbox
CVE-2026-61438GHSA-26mh-57q7-jfvr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.78), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI praisonai
- Affected
- < 4.6.78
- Fixed in
- 4.6.78
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-26mh-57q7-jfvr lists affected ranges: PyPI praisonai >=0 <4.6.78
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-26mh-57q7-jfvr lists affected ranges: PyPI praisonai >=0 <4.6.78 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-61438: 0.31% estimated exploitation activity in the next 30 days; percentile 23.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary JobWorkflowExecutor._exec_inline_python() is designed to safely execute inline Python expressions from YAML workflow script: steps using AST validation. The function claims to block dangerous operations by (a) checking all AST nodes against an allowlist, and (b) providing a builtins whitelist that omits import, exec, eval, and open. The sandbox is broken. The module import allowlist (allowed_modules) explicitly includes 'os', and the AST allowlist permits ast.Import, ast.ImportFrom, ast.Call, and ast.Attribute nodes. This means the following malicious workflow script: step passes all AST validation checks and executes without error. Attack Scenario Attacker creates or contributes a YAML workflow file (type: job) with a script: step containing import os; os.system(...). A user or CI pipeline with PRAISONAI_ALLOW_JOB_WORKFLOWS=true executes the workflow via praisonai workflow run malicious.yaml. Arbitrary OS commands execute with the privileges of the calling…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-26mh-57q7-jfvr
- Revision 1 · created ·
Published from ghsa record GHSA-26mh-57q7-jfvr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-61438 Advisory: PraisonAI vulnerable to Remote Code Execution via Broken AST Sandbox IDs: CVE-2026-61438, GHSA-26mh-57q7-jfvr Record: https://patchnext.com/advisories/cve-2026-61438 (revision 2, source checked 30 Oct 2026, 06:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.78. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI praisonai: affected < 4.6.78; fixed in 4.6.78 ## Suggested inspection (read-only) - `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on praisonai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-26mh-57q7-jfvr (GitHub-reviewed advisory GHSA-26mh-57q7-jfvr lists affected ranges: PyPI praisonai >=0 <4.6.78) - Verified: https://osv.dev/vulnerability/GHSA-26mh-57q7-jfvr (OSV record GHSA-26mh-57q7-jfvr lists affected ranges: PyPI praisonai >=0 <4.6.78 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…