Skip to content

← Actionable
Medium, CVSS 5.5amended

PraisonAI: ContextGatherer include resolution permits absolute and traversal reads outside the workspace

CVE-2026-61431GHSA-q7m5-3jmv-vm48

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.78), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    <= 4.6.77
    Fixed in
    4.6.78

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-61431: 0.37% estimated exploitation activity in the next 30 days; percentile 31.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ContextGatherer include resolution permits absolute and traversal reads outside the workspace Summary PraisonAI's praisonai.ui.context.ContextGatherer treats the configured directory as the project workspace, but project-controlled .praisoncontext and .praisoninclude files can name absolute paths or .. traversal paths. When context gathering runs, PraisonAI opens those outside paths and appends their contents to the generated context bundle. An attacker who can supply or modify a workspace repository can therefore cause process-readable files outside the intended project root to be sent to the caller or model as project context. Technical Details ContextGatherer.getincludepaths() reads include entries directly from .praisoncontext and .praisoninclude under the configured workspace. It stores each non-comment line as a raw include path: When .praisoncontext is present, gathercontext() passes every include entry through os.path.join(self.directory, includepath) and then processes the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q7m5-3jmv-vm48

  2. Revision 2 · amended ·

    Amended from osv record GHSA-q7m5-3jmv-vm48

  3. Revision 1 · created ·

    Published from ghsa record GHSA-q7m5-3jmv-vm48

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61431

Advisory: PraisonAI: ContextGatherer include resolution permits absolute and traversal reads outside the workspace
IDs: CVE-2026-61431, GHSA-q7m5-3jmv-vm48
Record: https://patchnext.com/advisories/cve-2026-61431 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.78. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected <= 4.6.77; fixed in 4.6.78

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q7m5-3jmv-vm48 (GitHub-reviewed advisory GHSA-q7m5-3jmv-vm48 lists affected ranges: PyPI praisonai >=0 <=4.6.77)
- Verified: https://osv.dev/vulnerability/GHSA-q7m5-3jmv-vm48 (OSV record GHSA-q7m5-3jmv-vm48 lists affected ranges: PyPI praisonai >=0 <4.6.78 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…