Skip to content

← Actionable
High, CVSS 7.3amended

PraisonAI: MCP HTTP-stream transport is unauthenticated by default, exposing tool enumeration and an unvalidated tool-call surface

CVE-2026-61427GHSA-hc5v-gxvj-58wh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.78), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    <= 4.6.77
    Fixed in
    4.6.78

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-61427: 0.43% estimated exploitation activity in the next 30 days; percentile 36.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PraisonAI's MCP HTTP-stream server authenticates requests only when an API key is configured; the CLI defaults --api-key to None, so praisonai mcp serve --transport http-stream exposes the full MCP surface unauthenticated. A request with no Authorization (and no Origin) can initialize and tools/list (~50 tools), and the dispatcher forwards tool-call arguments to handlers without validating them against the advertised inputSchema. Runtime-confirmed for unauthenticated initialize/tools/list and the dispatcher schema-bypass. This is not an RCE/file-read in 4.6.63 — workflow.run/workflow.runfile are runtime-refuted (adapter regression). Severity Medium–High. Details Affected component - Package: praisonai 4.6.63. Files: src/praisonai/praisonai/mcpserver/transports/httpstream.py, mcpserver/cli.py, mcpserver/server.py (dispatcher). Vulnerable code / root cause Path: src/praisonai/praisonai/mcpserver/transports/httpstream.py Function: mcppost / validateorigin Snippet: Issue: with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hc5v-gxvj-58wh

  2. Revision 2 · amended ·

    Amended from osv record GHSA-hc5v-gxvj-58wh

  3. Revision 1 · created ·

    Published from ghsa record GHSA-hc5v-gxvj-58wh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61427

Advisory: PraisonAI: MCP HTTP-stream transport is unauthenticated by default, exposing tool enumeration and an unvalidated tool-call surface
IDs: CVE-2026-61427, GHSA-hc5v-gxvj-58wh
Record: https://patchnext.com/advisories/cve-2026-61427 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.78. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected <= 4.6.77; fixed in 4.6.78

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hc5v-gxvj-58wh (GitHub-reviewed advisory GHSA-hc5v-gxvj-58wh lists affected ranges: PyPI praisonai >=0 <=4.6.77)
- Verified: https://osv.dev/vulnerability/GHSA-hc5v-gxvj-58wh (OSV record GHSA-hc5v-gxvj-58wh lists affected ranges: PyPI praisonai >=0 <4.6.78 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…