Skip to content

← Actionable
High, CVSS 8.6amended

PraisonAI: AgentOS defaults to network-exposed no-auth mode, allowing unauthenticated agent invocation and instruction disclosure

CVE-2026-61426GHSA-6wjp-v33h-5cvq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 1.7.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2026-61426: 0.40% estimated exploitation activity in the next 30 days; percentile 34.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The AgentOS server in the praisonai TypeScript/npm package ships an insecure default: it binds 0.0.0.0, sets no API key, and uses CORS with credentials. The API-key middleware is only registered when an API key is configured, so the documented quickstart (new AgentOS({agents:[...]}).serve({port})) exposes, unauthenticated, GET /api/agents (which leaks agent names/roles/instructions, i.e. system prompts) and POST /api/chat (which invokes agents). Any network peer can read agent system prompts and drive the agent. Runtime-confirmed; severity High. Details Affected component - Package: praisonai (npm / TypeScript). Files src/praisonai-ts/src/os/config.ts and src/praisonai-ts/src/os/agentos.ts (AgentOS). Vulnerable code / root cause Path: src/praisonai-ts/src/os/config.ts Class/const: DEFAULTAGENTOSCONFIG / mergeConfig Snippet: Issue: defaults bind all interfaces, with an empty API key and wildcard CORS. apiKey stays empty unless the developer explicitly sets it. Path:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6wjp-v33h-5cvq

  2. Revision 2 · amended ·

    Amended from osv record GHSA-6wjp-v33h-5cvq

  3. Revision 1 · created ·

    Published from ghsa record GHSA-6wjp-v33h-5cvq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-61426

Advisory: PraisonAI: AgentOS defaults to network-exposed no-auth mode, allowing unauthenticated agent invocation and instruction disclosure
IDs: CVE-2026-61426, GHSA-6wjp-v33h-5cvq
Record: https://patchnext.com/advisories/cve-2026-61426 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 1.7.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm praisonai: affected < 1.7.3; fixed in 1.7.3

## Suggested inspection (read-only)
- `npm ls praisonai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6wjp-v33h-5cvq (GitHub-reviewed advisory GHSA-6wjp-v33h-5cvq lists affected ranges: npm praisonai >=0 <1.7.3)
- Verified: https://osv.dev/vulnerability/GHSA-6wjp-v33h-5cvq (OSV record GHSA-6wjp-v33h-5cvq lists affected ranges: npm praisonai >=0 <1.7.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…