Skip to content

← Actionable
Medium, CVSS 5.3amended

Mattermost doesn't validate that a username returned during bot registration belongs to a bot account

CVE-2026-6046GHSA-3vmp-whvv-5v9v

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/mattermost/mattermost/server/v8

    Affected
    >= 8.0.0-20250731163400-5b955468ea1e, < 8.0.0-20260428151657-c79c3831061a
    Fixed in
    8.0.0-20260428151657-c79c3831061a
  • Go github.com/mattermost/mattermost-server/v6

    Affected
    every version
    Fixed in
    no fixed version recorded
  • Go github.com/mattermost/mattermost-server

    Affected
    >= 11.6.0, <= 11.6.0>= 11.5.0, <= 11.5.4>= 10.11.0, <= 10.11.15
    Fixed in
    10.11.17, 11.5.5, 11.6.1
  • Go github.com/mattermost/mattermost-server/v5

    Affected
    every version
    Fixed in
    no fixed version recorded

Sources

  • Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database

    OSV record GO-2026-6279 lists affected ranges: Go github.com/mattermost/mattermost-server >=10.11.0+incompatible =11.5.0+incompatible =11.6.0+incompatible =0; Go github.com/mattermost/mattermost-server/v6 >=0; Go github.com/mattermost/mattermost/server/v8 >=8.0.0-20250731163400-5b955468ea1e <8.0.0-20260428151657-c79c3831061a (fixed)

    VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-3vmp-whvv-5v9v lists affected ranges: Go github.com/mattermost/mattermost-server >=11.6.0 =11.5.0 =10.11.0 =8.0.0-20250731163400-5b955468ea1e <8.0.0-20260428151657-c79c3831061a

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-6046: 0.19% estimated exploitation activity in the next 30 days; percentile 8.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 fail to validate that a username returned during bot registration belongs to a bot account, which allows an unprivileged attacker to intercept private messages sent by plugins via direct message channels by pre-registering a user account with a predictable plugin bot username. Mattermost Advisory ID: MMSA-2026-00649

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3vmp-whvv-5v9v

  2. Revision 1 · created ·

    Published from osv record GO-2026-6279

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-6046

Advisory: Mattermost doesn't validate that a username returned during bot registration belongs to a bot account
IDs: CVE-2026-6046, GHSA-3vmp-whvv-5v9v
Record: https://patchnext.com/advisories/cve-2026-6046 (revision 2, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20260428151657-c79c3831061a; github.com/mattermost/mattermost-server 11.6.1, 11.5.5, 10.11.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected >= 8.0.0-20250731163400-5b955468ea1e, < 8.0.0-20260428151657-c79c3831061a; fixed in 8.0.0-20260428151657-c79c3831061a
- Go github.com/mattermost/mattermost-server/v6: affected every version
- Go github.com/mattermost/mattermost-server: affected >= 11.6.0, <= 11.6.0; >= 11.5.0, <= 11.5.4; >= 10.11.0, <= 10.11.15; fixed in 10.11.17, 11.5.5, 11.6.1
- Go github.com/mattermost/mattermost-server/v5: affected every version

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server/v6: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server/v5: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v6, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6279 (OSV record GO-2026-6279 lists affected ranges: Go github.com/mattermost/mattermost-server >=10.11.0+incompatible =11.5.0+incompatible =11.6.0+incompatible =0; Go github.com/mattermost/mattermost-server/v6 >=0; Go github.com/mattermost/mattermost/server/v8 >=8.0.0-20250731163400-5b955468ea1e <8.0.0-20260428151657-c79c3831061a (fixed))
- Verified: https://github.com/advisories/GHSA-3vmp-whvv-5v9v (GitHub-reviewed advisory GHSA-3vmp-whvv-5v9v lists affected ranges: Go github.com/mattermost/mattermost-server >=11.6.0 =11.5.0 =10.11.0 =8.0.0-20250731163400-5b955468ea1e <8.0.0-20260428151657-c79c3831061a)

Commands are suggestions: review each one before running it.

Loading voting…