PraisonAI: Prompt-injection defense blocks only when 3+ detector families fire simultaneously; realistic single-vector injections pass through unblocked
CVE-2026-60086GHSA-4r3p-w3mc-5v34
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.6.78), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI praisonai
- Affected
- <= 4.6.77
- Fixed in
- 4.6.78
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4r3p-w3mc-5v34 lists affected ranges: PyPI praisonai >=0 <=4.6.77
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4r3p-w3mc-5v34 lists affected ranges: PyPI praisonai >=0 <4.6.78 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-60086: 0.27% estimated exploitation activity in the next 30 days; percentile 18.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary PraisonAI's opt-in prompt-injection defense (enableinjectiondefense()) only blocks at ThreatLevel.CRITICAL, which requires three or more distinct detector families to match simultaneously. A realistic single- or double-vector prompt injection (e.g. "Ignore all previous instructions…") is classified HIGH and passes through unmodified. The documented HIGH "sanitize" behavior is not implemented. Root cause scantext sets blocked = (level = ThreatLevel.CRITICAL) and not istrusted (src/praisonai/praisonai/security/injection.py, around line 236). The severity ladder (around lines 223-233) reaches CRITICAL only when 3+ detector families fire; 1-2 checks yield HIGH, which never blocks. The ThreatLevel docstring declares HIGH = 2
Log + warn; sanitize, but no code path mutates the text at this level. Proof of concept Impact When the defense is enabled, ordinary prompt-injection payloads still reach the model and tools. An attacker only needs to avoid tripping 3+ regex families…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4r3p-w3mc-5v34
- Revision 2 · amended ·
Amended from osv record GHSA-4r3p-w3mc-5v34
- Revision 1 · created ·
Published from ghsa record GHSA-4r3p-w3mc-5v34
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-60086 Advisory: PraisonAI: Prompt-injection defense blocks only when 3+ detector families fire simultaneously; realistic single-vector injections pass through unblocked IDs: CVE-2026-60086, GHSA-4r3p-w3mc-5v34 Record: https://patchnext.com/advisories/cve-2026-60086 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: praisonai 4.6.78. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI praisonai: affected <= 4.6.77; fixed in 4.6.78 ## Suggested inspection (read-only) - `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on praisonai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4r3p-w3mc-5v34 (GitHub-reviewed advisory GHSA-4r3p-w3mc-5v34 lists affected ranges: PyPI praisonai >=0 <=4.6.77) - Verified: https://osv.dev/vulnerability/GHSA-4r3p-w3mc-5v34 (OSV record GHSA-4r3p-w3mc-5v34 lists affected ranges: PyPI praisonai >=0 <4.6.78 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…