psd-tools composite/numpy has uncontrolled memory allocation via crafted PSD geometry
CVE-2026-59991GHSA-8q6g-vjhf-jp8m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (psd-tools 1.17.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI psd-tools
- Affected
- < 1.17.4
- Fixed in
- 1.17.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8q6g-vjhf-jp8m lists affected ranges: PyPI psd-tools >=0 <1.17.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8q6g-vjhf-jp8m lists affected ranges: PyPI psd-tools >=0 <1.17.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-59991: 0.52% estimated exploitation activity in the next 30 days; percentile 44.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary PSDImage.composite() (and .numpy()) allocate the output image buffer from the PSD's header geometry (width × height × channels × depth, and per-layer rectangles) before validating those values against the actual file contents. A tiny crafted PSD declaring huge dimensions causes a multi-gigabyte allocation. Critically, composite() then returns a (black) image with only a warning, no exception is raised, so a caller cannot detect or guard against it. Impact On psd-tools 1.17.2 (latest), default usage, a 49-byte PSD makes composite() commit ~3 GB and return successfully (warning only); .numpy() reaches ~7.5 GB, and the per-layer rectangle is a second lever (up to ~32 GB), all from an input under 100 bytes (input-to-commit amplification over 1000×). Because the buffer is committed before validation and no exception is thrown, any service that composites untrusted PSDs is exposed to denial of service: on a host with less RAM than the attacker-declared geometry the allocation is an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8q6g-vjhf-jp8m
- Revision 2 · amended ·
Amended from osv record GHSA-8q6g-vjhf-jp8m
- Revision 1 · created ·
Published from ghsa record GHSA-8q6g-vjhf-jp8m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59991 Advisory: psd-tools composite/numpy has uncontrolled memory allocation via crafted PSD geometry IDs: CVE-2026-59991, GHSA-8q6g-vjhf-jp8m Record: https://patchnext.com/advisories/cve-2026-59991 (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: psd-tools 1.17.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI psd-tools: affected < 1.17.4; fixed in 1.17.4 ## Suggested inspection (read-only) - `python -m pip show psd-tools`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on psd-tools. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8q6g-vjhf-jp8m (GitHub-reviewed advisory GHSA-8q6g-vjhf-jp8m lists affected ranges: PyPI psd-tools >=0 <1.17.4) - Verified: https://osv.dev/vulnerability/GHSA-8q6g-vjhf-jp8m (OSV record GHSA-8q6g-vjhf-jp8m lists affected ranges: PyPI psd-tools >=0 <1.17.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…