Jawn: Uncontrolled nesting depth in JSON parser
CVE-2026-59990GHSA-cc4v-rvgp-2pf3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.typelevel:jawn-parser_2.13 1.7.0; org.typelevel:jawn-parser_2.12 1.7.0; org.typelevel:jawn-parser_3 1.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.typelevel:jawn-parser_2.13
- Affected
- <= 1.6.0
- Fixed in
- 1.7.0
Maven org.typelevel:jawn-parser_2.12
- Affected
- <= 1.6.0
- Fixed in
- 1.7.0
Maven org.typelevel:jawn-parser_3
- Affected
- <= 1.6.0
- Fixed in
- 1.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cc4v-rvgp-2pf3 lists affected ranges: Maven org.typelevel:jawn-parser_2.12 >=0 =0 =0 <1.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cc4v-rvgp-2pf3 lists affected ranges: Maven org.typelevel:jawn-parser_2.12 >=0 =0 =0 <=1.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-59990: 0.61% estimated exploitation activity in the next 30 days; percentile 49.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Jawn parser before 1.6.1 is vulnerable to a denial of service attack via untrusted input. Impact A remote attacker who can submit JSON to any jawn-backed parse method can exhaust JVM heap and trigger java.lang.OutOfMemoryError. This is treated by Scala as a fatal error and not typically handled by scala.util.Try or cats.effect.IO. Patches Version 1.6.1 introduces a configurable nesting-depth limit (Parser#maxDepth, default 4096). Inputs deeper than the limit fail with a recoverable ParseException instead of exhausting heap. Users who require deeper nesting may override maxDepth on a Parser subclass. Workarounds - Enforce an input size limit small enough that the resulting context stack cannot exhaust heap, (e.g. http4s EntityLimiter). - Pre-scan untrusted input and reject documents whose maximum delimiter nesting exceeds a threshold before handing them to jawn.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cc4v-rvgp-2pf3
- Revision 1 · created ·
Published from osv record GHSA-cc4v-rvgp-2pf3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59990 Advisory: Jawn: Uncontrolled nesting depth in JSON parser IDs: CVE-2026-59990, GHSA-cc4v-rvgp-2pf3 Record: https://patchnext.com/advisories/cve-2026-59990 (revision 2, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.typelevel:jawn-parser_2.13 1.7.0; org.typelevel:jawn-parser_2.12 1.7.0; org.typelevel:jawn-parser_3 1.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.typelevel:jawn-parser_2.13: affected <= 1.6.0; fixed in 1.7.0 - Maven org.typelevel:jawn-parser_2.12: affected <= 1.6.0; fixed in 1.7.0 - Maven org.typelevel:jawn-parser_3: affected <= 1.6.0; fixed in 1.7.0 ## Suggested inspection (read-only) - Maven org.typelevel:jawn-parser_2.13: check the installed version with your package manager. - Maven org.typelevel:jawn-parser_2.12: check the installed version with your package manager. - Maven org.typelevel:jawn-parser_3: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.typelevel:jawn-parser_2.13, org.typelevel:jawn-parser_2.12, org.typelevel:jawn-parser_3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cc4v-rvgp-2pf3 (OSV record GHSA-cc4v-rvgp-2pf3 lists affected ranges: Maven org.typelevel:jawn-parser_2.12 >=0 =0 =0 <1.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-cc4v-rvgp-2pf3 (GitHub-reviewed advisory GHSA-cc4v-rvgp-2pf3 lists affected ranges: Maven org.typelevel:jawn-parser_2.12 >=0 =0 =0 <=1.6.0) Commands are suggestions: review each one before running it.
Loading voting…