Skip to content

← Actionable
High, CVSS 7.5amended

AdminNeo: version-cache array injection causes persistent denial of service

CVE-2026-59978GHSA-jm85-8cpp-9cjc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (adminneo-org/adminneo 5.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-59978: 0.65% estimated exploitation activity in the next 30 days; percentile 51.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary AdminNeo v5.4.1 gets the latest version from GitHub API in a browser JavaScript function. Version number is then sent by POST request to `?script=version`. This endpoint lacks origin validation and accepts POST data from any source. An attacker can POST `version[]` parameter which PHP converts to an array. On next page load, function `rawurlencode()` receives this array instead of string and throws `TypeError`, returning HTTP 500 to all users for the next 24 hours. Originally reported by @JoyGhoshs in Adminer: https://github.com/vrana/adminer/security/advisories/GHSA-q4f2-39gr-45jh Although the version checking process was modified in AdminNeo, the root cause persisted.

Workaround If you can't upgrade, make the file `adminneo.version` in temp directory (usually the value of upload_tmp_dir) unwritable by web server.

Details

1. Intended design of `?script=version` The endpoint is designed to receive version…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-jm85-8cpp-9cjc

  2. Revision 1 · created ·

    Published from ghsa record GHSA-jm85-8cpp-9cjc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59978

Advisory: AdminNeo: version-cache array injection causes persistent denial of service
IDs: CVE-2026-59978, GHSA-jm85-8cpp-9cjc
Record: https://patchnext.com/advisories/cve-2026-59978 (revision 2, source checked 31 Oct 2026, 06:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: adminneo-org/adminneo 5.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist adminneo-org/adminneo: affected >= 4.6.2, < 5.5.0; fixed in 5.5.0

## Suggested inspection (read-only)
- Packagist adminneo-org/adminneo: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on adminneo-org/adminneo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jm85-8cpp-9cjc (GitHub-reviewed advisory GHSA-jm85-8cpp-9cjc lists affected ranges: Packagist adminneo-org/adminneo >=4.6.2 <5.5.0)
- Verified: https://osv.dev/vulnerability/GHSA-jm85-8cpp-9cjc (OSV record GHSA-jm85-8cpp-9cjc lists affected ranges: Packagist adminneo-org/adminneo >=4.6.2 <5.5.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…