FrontMCP and mcp-from-openapi have bypass of OpenAPI external $ref SSRF fix
CVE-2026-59973GHSA-65h7-9wrw-629c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-from-openapi 2.5.0; @frontmcp/adapters 1.5.0; frontmcp 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mcp-from-openapi
- Affected
- >= 2.3.0, < 2.5.0
- Fixed in
- 2.5.0
- Affected
- >= 1.2.1, < 1.5.0
- Fixed in
- 1.5.0
npm frontmcp
- Affected
- >= 1.2.1, < 1.5.0
- Fixed in
- 1.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-65h7-9wrw-629c lists affected ranges: npm mcp-from-openapi >=2.3.0 =1.2.1 =1.2.1 <1.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-65h7-9wrw-629c lists affected ranges: npm mcp-from-openapi >=2.3.0 =1.2.1 =1.2.1 <1.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-59973: 0.39% estimated exploitation activity in the next 30 days; percentile 33.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The published fix for GHSA-v6ph-xcq9-qxxj / CVE-2026-39885 added a direct hostname denylist for OpenAPI external $ref dereferencing, but the latest patched dependency mcp-from-openapi 2.3.0 still makes backend-origin requests to loopback when the target is reached through hostname resolution, redirects, or IPv4-mapped IPv6 syntax. FrontMCP latest release v1.2.1 and current main still call OpenAPIToolGenerator.fromURL() and OpenAPIToolGenerator.fromJSON() from mcp-from-openapi 2.3.0 when loading OpenAPI adapters. An attacker who can cause a hosted or multi-user FrontMCP deployment to load an untrusted OpenAPI spec can trigger requests from the server to localhost or private services during tool generation. This is a latest-version bypass of the previous fix. A direct http://127.0.0.1 $ref control is now denied and produces zero canary hits, while semantically equivalent loopback targets still reach the canary. Latest versions checked - frontmcp npm latest: 1.2.1 -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-65h7-9wrw-629c
- Revision 2 · amended ·
Amended from osv record GHSA-65h7-9wrw-629c
- Revision 1 · created ·
Published from ghsa record GHSA-65h7-9wrw-629c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59973 Advisory: FrontMCP and mcp-from-openapi have bypass of OpenAPI external $ref SSRF fix IDs: CVE-2026-59973, GHSA-65h7-9wrw-629c Record: https://patchnext.com/advisories/cve-2026-59973 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mcp-from-openapi 2.5.0; @frontmcp/adapters 1.5.0; frontmcp 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mcp-from-openapi: affected >= 2.3.0, < 2.5.0; fixed in 2.5.0 - npm @frontmcp/adapters: affected >= 1.2.1, < 1.5.0; fixed in 1.5.0 - npm frontmcp: affected >= 1.2.1, < 1.5.0; fixed in 1.5.0 ## Suggested inspection (read-only) - `npm ls mcp-from-openapi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @frontmcp/adapters --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls frontmcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mcp-from-openapi, @frontmcp/adapters, frontmcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-65h7-9wrw-629c (GitHub-reviewed advisory GHSA-65h7-9wrw-629c lists affected ranges: npm mcp-from-openapi >=2.3.0 =1.2.1 =1.2.1 <1.5.0) - Verified: https://osv.dev/vulnerability/GHSA-65h7-9wrw-629c (OSV record GHSA-65h7-9wrw-629c lists affected ranges: npm mcp-from-openapi >=2.3.0 =1.2.1 =1.2.1 <1.5.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…