@jhb.software/payload-alt-text-plugin: Alt Text Endpoint Authorization Bypass via Payload Local API overrideAccess Omission
CVE-2026-59965GHSA-4qpv-39hg-f7fx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@jhb.software/payload-alt-text-plugin 0.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @jhb.software/payload-alt-text-plugin
- Affected
- < 0.8.0
- Fixed in
- 0.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4qpv-39hg-f7fx lists affected ranges: npm @jhb.software/payload-alt-text-plugin >=0 <0.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4qpv-39hg-f7fx lists affected ranges: npm @jhb.software/payload-alt-text-plugin >=0 <0.8.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
- EPSS
- CVE-2026-59965: 0.38% estimated exploitation activity in the next 30 days; percentile 31.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Alt Text Endpoint Authorization Bypass via Payload Local API overrideAccess Omission Summary @jhb.software/payload-alt-text-plugin v0.7.0 exposes custom Payload CMS endpoints (POST /api/alt-text-plugin/generate and /bulk) that call the Payload Local API (findByID and update) without setting overrideAccess: false. Because Payload's internal logic evaluates shouldOverrideAccess = overrideAccess !== false, omitting the parameter causes it to default to true, silently bypassing all collection-level access control functions. Any authenticated user — regardless of role — can read and overwrite the alt and keywords fields of arbitrary upload documents that would otherwise be protected by restrictive collection access rules. The vulnerability is rated High (CVSS 7.1). Details The plugin registers two network endpoints in alt-text/src/plugin.ts:179-186. Their default access guard (plugin.ts:55) only checks !!req.user, meaning any authenticated session satisfies the check regardless of the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4qpv-39hg-f7fx
- Revision 2 · amended ·
Amended from osv record GHSA-4qpv-39hg-f7fx
- Revision 1 · created ·
Published from ghsa record GHSA-4qpv-39hg-f7fx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59965 Advisory: @jhb.software/payload-alt-text-plugin: Alt Text Endpoint Authorization Bypass via Payload Local API `overrideAccess` Omission IDs: CVE-2026-59965, GHSA-4qpv-39hg-f7fx Record: https://patchnext.com/advisories/cve-2026-59965 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @jhb.software/payload-alt-text-plugin 0.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @jhb.software/payload-alt-text-plugin: affected < 0.8.0; fixed in 0.8.0 ## Suggested inspection (read-only) - `npm ls @jhb.software/payload-alt-text-plugin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @jhb.software/payload-alt-text-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4qpv-39hg-f7fx (GitHub-reviewed advisory GHSA-4qpv-39hg-f7fx lists affected ranges: npm @jhb.software/payload-alt-text-plugin >=0 <0.8.0) - Verified: https://osv.dev/vulnerability/GHSA-4qpv-39hg-f7fx (OSV record GHSA-4qpv-39hg-f7fx lists affected ranges: npm @jhb.software/payload-alt-text-plugin >=0 <0.8.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…