Composer: Path traversal in package bin field lets dependencies chmod arbitrary host files
CVE-2026-59946GHSA-gjfg-22fp-rrxx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (composer/composer 2.10.2, 2.2.29), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist composer/composer
- Affected
- >= 2.3.0, < 2.10.2>= 1.0.0, < 2.2.29
- Fixed in
- 2.2.29, 2.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gjfg-22fp-rrxx lists affected ranges: Packagist composer/composer >=2.3.0 =1.0.0 <2.2.29
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-59946: 0.14% estimated exploitation activity in the next 30 days; percentile 3.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Composer package declares its executables in the bin field of its composer.json. When Composer installs a package, it processes each bin entry and changes the file mode of the corresponding file so it is executable. If a bin entry contains .. path segments, it can resolve to a path outside the package's own install directory. A malicious package can use this to make Composer run chmod against a file that already exists elsewhere on the machine. The resulting mode is world-readable and world-executable (0755 under the common umask of 022). This happens when the package is installed, e.g. during composer install, composer update, and composer require. Any dependency can trigger it, including a transitive dependency several levels deep. The vulnerability changes file permissions only, and does not read, modify, or execute the contents of the target file, and it is not remote code execution. The impact is to confidentiality: a file with deliberately restrictive permissions,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gjfg-22fp-rrxx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59946 Advisory: Composer: Path traversal in package bin field lets dependencies chmod arbitrary host files IDs: CVE-2026-59946, GHSA-gjfg-22fp-rrxx Record: https://patchnext.com/advisories/cve-2026-59946 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: composer/composer 2.10.2, 2.2.29. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist composer/composer: affected >= 2.3.0, < 2.10.2; >= 1.0.0, < 2.2.29; fixed in 2.2.29, 2.10.2 ## Suggested inspection (read-only) - Packagist composer/composer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on composer/composer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gjfg-22fp-rrxx (GitHub-reviewed advisory GHSA-gjfg-22fp-rrxx lists affected ranges: Packagist composer/composer >=2.3.0 =1.0.0 <2.2.29) Commands are suggestions: review each one before running it.
Loading voting…