Composer: GHSA-gjfg-22fp-rrxx fix bypass via symlinked package bin path
CVE-2026-59944GHSA-96h3-5x6v-m776
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (composer/composer 2.10.3, 2.2.30), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist composer/composer
- Affected
- >= 2.3.0, < 2.10.3>= 1.0, < 2.2.30
- Fixed in
- 2.10.3, 2.2.30
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-96h3-5x6v-m776 lists affected ranges: Packagist composer/composer >=2.3.0 =1.0 =1.0.0-alpha1 =1.0.0-alpha10 =1.0.0-alpha11 =1.0.0-alpha2 =1.0.0-alpha3 =1.0.0-alpha4 =1.0.0-alpha5 =1.0.0-alpha6 =1.0.0-alpha7 =1.0.0-alpha8 =1.0.0-alpha9 =1.0.0-beta1…
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-96h3-5x6v-m776 lists affected ranges: Packagist composer/composer >=2.3.0 =1.0 <2.2.30
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-59944: 0.47% estimated exploitation activity in the next 30 days; percentile 40.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A malicious or compromised Composer package could, when installed as a dependency, cause Composer to change the permissions of a file outside that package's own directory and to register a runnable vendor/bin command that points at that outside file. This is a path traversal and link following issue. It is not remote code execution, the attacker gains no ability to read or receive your data directly. The risk is that a file which was readable only by its owner, but modifiable by Composer, can be made world readable and executable, which is enough to expose its contents on a shared or multi tenant host. The earlier hardening from GHSA-gjfg-22fp-rrxx can be bypassed, since it only rejected literal .. path segments in a package's declared binaries, and was only applied in a single place during dependency resolution. Am I affected? You can be affected if a malicious or compromised package, including a transitive dependency, is installed in your project, and either of the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-96h3-5x6v-m776
- Revision 1 · created ·
Published from osv record GHSA-96h3-5x6v-m776
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59944 Advisory: Composer: GHSA-gjfg-22fp-rrxx fix bypass via symlinked package bin path IDs: CVE-2026-59944, GHSA-96h3-5x6v-m776 Record: https://patchnext.com/advisories/cve-2026-59944 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: composer/composer 2.10.3, 2.2.30. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist composer/composer: affected >= 2.3.0, < 2.10.3; >= 1.0, < 2.2.30; fixed in 2.10.3, 2.2.30 ## Suggested inspection (read-only) - Packagist composer/composer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on composer/composer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-96h3-5x6v-m776 (OSV record GHSA-96h3-5x6v-m776 lists affected ranges: Packagist composer/composer >=2.3.0 =1.0 =1.0.0-alpha1 =1.0.0-alpha10 =1.0.0-alpha11 =1.0.0-alpha2 =1.0.0-alpha3 =1.0.0-alpha4 =1.0.0-alpha5 =1.0.0-alpha6 =1.0.0-alpha7 =1.0.0-alpha8 =1.0.0-alpha9 =1.0.0-beta1…) - Verified: https://github.com/advisories/GHSA-96h3-5x6v-m776 (GitHub-reviewed advisory GHSA-96h3-5x6v-m776 lists affected ranges: Packagist composer/composer >=2.3.0 =1.0 <2.2.30) Commands are suggestions: review each one before running it.
Loading voting…