seroval: seroval.fromJSON() Promise resolver type confusion invokes attacker-controlled methods during deserialization
CVE-2026-59940GHSA-mv8w-475r-vwqw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (seroval 1.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm seroval
- Affected
- <= 1.5.2
- Fixed in
- 1.5.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mv8w-475r-vwqw lists affected ranges: npm seroval >=0 <=1.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mv8w-475r-vwqw lists affected ranges: npm seroval >=0 <1.5.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-59940: 0.81% estimated exploitation activity in the next 30 days; percentile 57.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A type confusion issue in seroval.fromJSON() allowed attacker-controlled JSON input to cause Promise control nodes to operate on values from the general deserialization reference table without first verifying that those values were genuine internal promise resolver records. In applications that deserialize untrusted Seroval JSON with plugins enabled, this could allow attacker-controlled deserialization side effects. In downstream server frameworks that register plugins returning callable wrappers, this primitive could become unintended server-side invocation and, depending on exposed application functionality, remote code execution or equivalent server compromise. The issue was fixed in seroval@1.5.3. Affected package - Package: seroval - Affected API: fromJSON() - Affected versions: versions prior to 1.5.3 that contain the vulnerable Promise resolver reference handling - Patched version: 1.5.3 Impact The vulnerable deserialization path could confuse attacker-created values…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mv8w-475r-vwqw
- Revision 2 · amended ·
Amended from osv record GHSA-mv8w-475r-vwqw
- Revision 1 · created ·
Published from ghsa record GHSA-mv8w-475r-vwqw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59940 Advisory: seroval: `seroval.fromJSON()` Promise resolver type confusion invokes attacker-controlled methods during deserialization IDs: CVE-2026-59940, GHSA-mv8w-475r-vwqw Record: https://patchnext.com/advisories/cve-2026-59940 (revision 3, source checked 26 Oct 2026, 12:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: seroval 1.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm seroval: affected <= 1.5.2; fixed in 1.5.3 ## Suggested inspection (read-only) - `npm ls seroval --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on seroval. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mv8w-475r-vwqw (GitHub-reviewed advisory GHSA-mv8w-475r-vwqw lists affected ranges: npm seroval >=0 <=1.5.2) - Verified: https://osv.dev/vulnerability/GHSA-mv8w-475r-vwqw (OSV record GHSA-mv8w-475r-vwqw lists affected ranges: npm seroval >=0 <1.5.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…