Skip to content

← Actionable
High, CVSS 7.5amended

httplib2: Decompression Bomb Denial of Service via Unbounded gzip/deflate Response Handling

CVE-2026-59939GHSA-j5g9-f88f-gfj3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (httplib2 0.32.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI httplib2

    Affected
    < 0.32.0
    Fixed in
    0.32.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-59939: 0.66% estimated exploitation activity in the next 30 days; percentile 51.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The httplib2 HTTP client library performs unbounded decompression of HTTP response bodies encoded with Content-Encoding: gzip or deflate. A malicious or compromised HTTP server can return a small compressed payload (approximately 150 KB) that expands to an arbitrarily large size in memory (150 MB or more), causing MemoryError or OOM-kill in the client process. This is a classic decompression bomb (zip bomb) attack against the HTTP client. Any application using httplib2.Http().request() against untrusted or attacker-controlled HTTP endpoints is affected. Details Affected code: httplib2/init.py - decompressContent() function The decompression path has two unbounded operations: 1. gzip decompression (line 394): The .read() call with no size argument decompresses the entire gzip payload into a single in-memory bytes object. There is no limit on the decompressed size. 2. deflate decompression (line 397): Similarly, zlib.decompress() returns the fully decompressed content as a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j5g9-f88f-gfj3

  2. Revision 1 · created ·

    Published from osv record GHSA-j5g9-f88f-gfj3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59939

Advisory: httplib2: Decompression Bomb Denial of Service via Unbounded gzip/deflate Response Handling
IDs: CVE-2026-59939, GHSA-j5g9-f88f-gfj3
Record: https://patchnext.com/advisories/cve-2026-59939 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: httplib2 0.32.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI httplib2: affected < 0.32.0; fixed in 0.32.0

## Suggested inspection (read-only)
- `python -m pip show httplib2`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on httplib2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j5g9-f88f-gfj3 (OSV record GHSA-j5g9-f88f-gfj3 lists affected ranges: PyPI httplib2 >=0 <0.32.0 (fixed))
- Verified: https://github.com/advisories/GHSA-j5g9-f88f-gfj3 (GitHub-reviewed advisory GHSA-j5g9-f88f-gfj3 lists affected ranges: PyPI httplib2 >=0 <0.32.0)

Commands are suggestions: review each one before running it.

Loading voting…