Skip to content

← Actionable
High, CVSS 7.5

PHPSpreadsheet: Gnumeric reader unbounded gzip expansion causes memory exhaustion

CVE-2026-59932GHSA-2mrg-gjxq-2gvr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpoffice/phpspreadsheet 5.8.1, 3.10.7, 2.4.7, 2.1.18, 1.30.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpoffice/phpspreadsheet

    Affected
    >= 4.0.0, <= 5.8.0>= 3.3.0, <= 3.10.6>= 2.2.0, <= 2.4.6>= 2.0.0, <= 2.1.17<= 1.30.5
    Fixed in
    2.1.18, 3.10.7, 2.4.7, 1.30.6, 5.8.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-59932: 0.46% estimated exploitation activity in the next 30 days; percentile 40.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PhpSpreadsheet's Gnumeric reader reads attacker-supplied .gnumeric files into memory and, when the file starts with gzip magic bytes, calls gzdecode() on the full compressed contents without enforcing a decompressed-size limit. A very small compressed .gnumeric file can expand to data larger than the PHP memory limit and crash the process during Gnumeric::canRead() before the file is rejected or fully parsed. This is reachable through normal file-type detection and Gnumeric loading paths, so applications that accept attacker-controlled spreadsheet uploads can suffer denial of service. Vulnerability details Gnumeric::canRead() invokes gzfileGetContents() before deciding whether the file is a valid Gnumeric spreadsheet: - src/PhpSpreadsheet/Reader/Gnumeric.php:80-90 calls $this-gzfileGetContents($filename) from canRead(). - src/PhpSpreadsheet/Reader/Gnumeric.php:105-115 calls canRead() and then reads the expanded contents again for worksheet-name listing. -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2mrg-gjxq-2gvr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59932

Advisory: PHPSpreadsheet: Gnumeric reader unbounded gzip expansion causes memory exhaustion
IDs: CVE-2026-59932, GHSA-2mrg-gjxq-2gvr
Record: https://patchnext.com/advisories/cve-2026-59932 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpoffice/phpspreadsheet 5.8.1, 3.10.7, 2.4.7, 2.1.18, 1.30.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpoffice/phpspreadsheet: affected >= 4.0.0, <= 5.8.0; >= 3.3.0, <= 3.10.6; >= 2.2.0, <= 2.4.6; >= 2.0.0, <= 2.1.17; <= 1.30.5; fixed in 2.1.18, 3.10.7, 2.4.7, 1.30.6, 5.8.1

## Suggested inspection (read-only)
- Packagist phpoffice/phpspreadsheet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpoffice/phpspreadsheet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2mrg-gjxq-2gvr (GitHub-reviewed advisory GHSA-2mrg-gjxq-2gvr lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 =2.2.0 =2.0.0 =0 <=1.30.5)

Commands are suggestions: review each one before running it.

Loading voting…