Mistune renderers/html.safe_url: HARMFUL_PROTOCOLS list misses legacy and chained schemes that historically chain to javascript: execution
CVE-2026-59929GHSA-qfrw-5rxm-mhh2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mistune 3.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mistune
- Affected
- < 3.3.0
- Fixed in
- 3.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qfrw-5rxm-mhh2 lists affected ranges: PyPI mistune >=0 <3.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qfrw-5rxm-mhh2 lists affected ranges: PyPI mistune >=0 <3.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-59929: 0.34% estimated exploitation activity in the next 30 days; percentile 27.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Type: URL-scheme allowlist gap. The safeurl filter only blocks the four schemes javascript:, vbscript:, file:, data:. Several other schemes are accepted into rendered <a href="..." and <img src="..." tags despite being known XSS vectors in legacy or chain-handling browsers. The same gap applies to direct links, reference links, and autolinks. File: src/mistune/renderers/html.py, line 11-23 (HARMFULPROTOCOLS list). Root cause: the HARMFULPROTOCOLS tuple is a hardcoded, opt-out denylist of four entries. Browsers historically supported (and some still partially support) several other schemes that either execute JavaScript directly (livescript:, mocha:) or wrap a javascript: payload (feed:javascript:, view-source:javascript:, jar:javascript:, ms-its:javascript:, mk:@MSITStore:javascript:). On user-agents that still recognise these schemes (older Firefox builds for feed:/jar:, all Internet Explorer / Edge Legacy for ms-its:/mk:/res:, niche chrome-style browsers, browser extensions…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qfrw-5rxm-mhh2
- Revision 1 · created ·
Published from osv record GHSA-qfrw-5rxm-mhh2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59929 Advisory: Mistune renderers/html.safe_url: HARMFUL_PROTOCOLS list misses legacy and chained schemes that historically chain to `javascript:` execution IDs: CVE-2026-59929, GHSA-qfrw-5rxm-mhh2 Record: https://patchnext.com/advisories/cve-2026-59929 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mistune 3.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mistune: affected < 3.3.0; fixed in 3.3.0 ## Suggested inspection (read-only) - `python -m pip show mistune`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mistune. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qfrw-5rxm-mhh2 (OSV record GHSA-qfrw-5rxm-mhh2 lists affected ranges: PyPI mistune >=0 <3.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-qfrw-5rxm-mhh2 (GitHub-reviewed advisory GHSA-qfrw-5rxm-mhh2 lists affected ranges: PyPI mistune >=0 <3.3.0) Commands are suggestions: review each one before running it.
Loading voting…