Netty: CRLF Injection via Multipart Filename in Netty HttpPostRequestEncoder
CVE-2026-59921GHSA-gcjf-9mgh-3p7g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-http 4.2.16.Final, 4.1.136.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-http
- Affected
- >= 4.2.0.Final, < 4.2.16.Final< 4.1.136.Final
- Fixed in
- 4.2.16.Final, 4.1.136.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gcjf-9mgh-3p7g lists affected ranges: Maven io.netty:netty-codec-http >=4.2.0.Final =0 <4.1.136.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.7 · CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-59921: 0.46% estimated exploitation activity in the next 30 days; percentile 40.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Security Vulnerability Report: CRLF Injection via Multipart Filename in Netty HttpPostRequestEncoder 1. Vulnerability Summary | Field | Value | |-------|-------| | Product | Netty | | Version | 4.2.12.Final (and all prior versions with codec-http multipart) | | Component | io.netty.handler.codec.http.multipart.HttpPostRequestEncoder | | Vulnerability Type | CWE-93: Improper Neutralization of CRLF Sequences / CWE-113: HTTP Response Splitting | | Impact | MIME Header Injection / Content-Type Spoofing / XSS via Content-Disposition | | CVSS 3.1 Score | 8.1 (High) | | CVSS 3.1 Vector | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N | | Attack Vector | Network | | Attack Complexity | Low | | Privileges Required | Low (attacker must be able to upload files with controlled filenames) | | User Interaction | None | | Scope | Unchanged | | Confidentiality Impact | High | | Integrity Impact | High | | Availability Impact | None | 2. Affected Components The following classes in the codec-http…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gcjf-9mgh-3p7g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59921 Advisory: Netty: CRLF Injection via Multipart Filename in Netty HttpPostRequestEncoder IDs: CVE-2026-59921, GHSA-gcjf-9mgh-3p7g Record: https://patchnext.com/advisories/cve-2026-59921 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-http 4.2.16.Final, 4.1.136.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-http: affected >= 4.2.0.Final, < 4.2.16.Final; < 4.1.136.Final; fixed in 4.2.16.Final, 4.1.136.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-http: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gcjf-9mgh-3p7g (GitHub-reviewed advisory GHSA-gcjf-9mgh-3p7g lists affected ranges: Maven io.netty:netty-codec-http >=4.2.0.Final =0 <4.1.136.Final) Commands are suggestions: review each one before running it.
Loading voting…