Netty: HAProxy V1 Protocol CRLF Injection via AF_UNIX Address
CVE-2026-59919GHSA-wh89-7897-x99h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-haproxy 4.2.16.Final, 4.1.136.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-haproxy
- Affected
- >= 4.2.0.Final, < 4.2.16.Final< 4.1.136.Final
- Fixed in
- 4.2.16.Final, 4.1.136.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wh89-7897-x99h lists affected ranges: Maven io.netty:netty-codec-haproxy >=4.2.0.Final =0 <4.1.136.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-59919: 0.17% estimated exploitation activity in the next 30 days; percentile 5.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Security Vulnerability Report: HAProxy V1 Protocol CRLF Injection via AFUNIX Address in Netty 1. Vulnerability Summary | Field | Value | |-------|-------| | Product | Netty | | Version | 4.2.12.Final (and all prior versions with codec-haproxy) | | Component | io.netty.handler.codec.haproxy.HAProxyMessageEncoder | | Vulnerability Type | CWE-93: Improper Neutralization of CRLF Sequences | | Impact | HAProxy PROXY Protocol Injection / Client IP Spoofing | | CVSS 3.1 Score | 7.5 (High) | | CVSS 3.1 Vector | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N | 2. Affected Components - io.netty.handler.codec.haproxy.HAProxyMessageEncoder — encodeV1() method (lines 63-77): writes sourceAddress and destinationAddress directly to output without CRLF validation - io.netty.handler.codec.haproxy.HAProxyMessage — constructor checkAddress() validates IPv4/IPv6 format but only checks length for AFUNIX (line 439) 3. Vulnerability Description Netty's HAProxy protocol encoder writes AFUNIX socket addresses…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wh89-7897-x99h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59919 Advisory: Netty: HAProxy V1 Protocol CRLF Injection via AF_UNIX Address IDs: CVE-2026-59919, GHSA-wh89-7897-x99h Record: https://patchnext.com/advisories/cve-2026-59919 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-haproxy 4.2.16.Final, 4.1.136.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-haproxy: affected >= 4.2.0.Final, < 4.2.16.Final; < 4.1.136.Final; fixed in 4.2.16.Final, 4.1.136.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-haproxy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-haproxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wh89-7897-x99h (GitHub-reviewed advisory GHSA-wh89-7897-x99h lists affected ranges: Maven io.netty:netty-codec-haproxy >=4.2.0.Final =0 <4.1.136.Final) Commands are suggestions: review each one before running it.
Loading voting…