Netty Vulnerable to Cache Poisoning and Information Disclosure via CORS Vary Header Overwrite
CVE-2026-59903GHSA-8c42-7qj2-3j46
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-http 4.2.17.Final, 4.1.137.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-http
- Affected
- >= 4.2.0.Final, <= 4.2.16.Final<= 4.1.136.Final
- Fixed in
- 4.2.17.Final, 4.1.137.Final
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8c42-7qj2-3j46 lists affected ranges: Maven io.netty:netty-codec-http >=4.2.0.Final =0 <4.1.137.Final (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8c42-7qj2-3j46 lists affected ranges: Maven io.netty:netty-codec-http >=4.2.0.Final =0 <=4.1.136.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-59903: 0.32% estimated exploitation activity in the next 30 days; percentile 25.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Netty's CorsHandler silently overwrites existing Vary headers, enabling cache poisoning and sensitive information disclosure. Details io.netty.handler.codec.http.cors.CorsHandler#setVaryHeader overwrites any existing Vary headers set by backend applications. Because set() replaces all existing values for the header, if a backend application sets a Vary header (such as Vary: Authorization or Vary: Cookie) to ensure that intermediate caches (like CDNs) cache responses separately per user, the CorsHandler will overwrite it with Vary: origin. This causes the caching proxy to ignore the authorization context and cache the response based solely on the URL and Origin, allowing an attacker to retrieve another user's cached sensitive data. Impact This is a Cache Poisoning vulnerability that leads to Information Disclosure. It impacts any Netty-based web application that uses the CorsHandler, sets its own Vary headers to manage caching of authenticated or user-specific responses (e.g.,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8c42-7qj2-3j46
- Revision 1 · created ·
Published from osv record GHSA-8c42-7qj2-3j46
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59903 Advisory: Netty Vulnerable to Cache Poisoning and Information Disclosure via CORS Vary Header Overwrite IDs: CVE-2026-59903, GHSA-8c42-7qj2-3j46 Record: https://patchnext.com/advisories/cve-2026-59903 (revision 2, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-http 4.2.17.Final, 4.1.137.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-http: affected >= 4.2.0.Final, <= 4.2.16.Final; <= 4.1.136.Final; fixed in 4.2.17.Final, 4.1.137.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-http: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8c42-7qj2-3j46 (OSV record GHSA-8c42-7qj2-3j46 lists affected ranges: Maven io.netty:netty-codec-http >=4.2.0.Final =0 <4.1.137.Final (fixed)) - Verified: https://github.com/advisories/GHSA-8c42-7qj2-3j46 (GitHub-reviewed advisory GHSA-8c42-7qj2-3j46 lists affected ranges: Maven io.netty:netty-codec-http >=4.2.0.Final =0 <=4.1.136.Final) Commands are suggestions: review each one before running it.
Loading voting…