Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation
CVE-2026-59898GHSA-4mp9-239f-g9hg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-http 4.2.16.Final, 4.1.136.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-http
- Affected
- >= 4.2.0.Final, <= 4.2.15.Final< 4.1.136.Final
- Fixed in
- 4.2.16.Final, 4.1.136.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4mp9-239f-g9hg lists affected ranges: Maven io.netty:netty-codec-http >=4.2.0.Final =0 <4.1.136.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-59898: 0.44% estimated exploitation activity in the next 30 days; percentile 38.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending Sec-WebSocket-Version: 7 and omitting Connection: Upgrade / Upgrade: websocket headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4mp9-239f-g9hg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59898 Advisory: Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation IDs: CVE-2026-59898, GHSA-4mp9-239f-g9hg Record: https://patchnext.com/advisories/cve-2026-59898 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-http 4.2.16.Final, 4.1.136.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-http: affected >= 4.2.0.Final, <= 4.2.15.Final; < 4.1.136.Final; fixed in 4.2.16.Final, 4.1.136.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-http: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4mp9-239f-g9hg (GitHub-reviewed advisory GHSA-4mp9-239f-g9hg lists affected ranges: Maven io.netty:netty-codec-http >=4.2.0.Final =0 <4.1.136.Final) Commands are suggestions: review each one before running it.
Loading voting…