Skip to content

← Actionable
High, CVSS 7.5amended

OpenTelemetry JavaScript: Denial of service in JaegerPropagator via unhandled exception on a malformed header

CVE-2026-59892GHSA-45rx-2jwx-cxfr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@opentelemetry/propagator-jaeger 2.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-59892: 0.56% estimated exploitation activity in the next 30 days; percentile 46.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary @opentelemetry/propagator-jaeger decodes incoming HTTP header values with decodeURIComponent() without handling decode errors. A single request carrying a malformed percent-encoded value (for example a bare %) in an uber-trace-id or uberctx- header throws an uncaught URIError, terminating any Node.js process that uses JaegerPropagator as its active propagator. Impact Denial of Service: Any unauthenticated remote attacker who can send an HTTP request to a service that has JaegerPropagator registered as the global propagator (e.g. via OTELPROPAGATORS=jaeger or propagation.setGlobalPropagator(new JaegerPropagator())) can terminate the process with a single request. Confidentiality and integrity are not affected. Am I affected? This issue affects only a specific, opt-in configuration. If you use OpenTelemetry's default propagators (W3C TraceContext and Baggage), you are not affected. You are affected only if you have registered JaegerPropagator as the active propagator. Check…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-45rx-2jwx-cxfr

  2. Revision 1 · created ·

    Published from osv record GHSA-45rx-2jwx-cxfr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59892

Advisory: OpenTelemetry JavaScript: Denial of service in `JaegerPropagator` via unhandled exception on a malformed header
IDs: CVE-2026-59892, GHSA-45rx-2jwx-cxfr
Record: https://patchnext.com/advisories/cve-2026-59892 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @opentelemetry/propagator-jaeger 2.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @opentelemetry/propagator-jaeger: affected < 2.9.0; fixed in 2.9.0

## Suggested inspection (read-only)
- `npm ls @opentelemetry/propagator-jaeger --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @opentelemetry/propagator-jaeger.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-45rx-2jwx-cxfr (OSV record GHSA-45rx-2jwx-cxfr lists affected ranges: npm @opentelemetry/propagator-jaeger >=0 <2.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-45rx-2jwx-cxfr (GitHub-reviewed advisory GHSA-45rx-2jwx-cxfr lists affected ranges: npm @opentelemetry/propagator-jaeger >=0 <2.9.0)

Commands are suggestions: review each one before running it.

Loading voting…