Skip to content

← Actionable
High, CVSS 7.5amended

linkify-it: Quadratic-complexity DoS via the mailto: validator scan-loop on attacker text

CVE-2026-59887GHSA-v245-v573-v5vm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (linkify-it 5.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-59887: 0.47% estimated exploitation activity in the next 30 days; percentile 40.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary linkify-it's schema-scan loop (.test() / .match(), the documented public API) invokes the mailto: schema validator at every mailto: occurrence in the input text. For each occurrence the validator does text.slice(pos) (an O(n) copy) and runs an email regex whose local-part class srcemailname greedily scans the entire remaining tail (O(n)) before failing. With N mailto: occurrences that is N × O(n) = O(n²). Because linkify-it runs on arbitrary user text (markdown-it feeds it whole documents when linkify:true), an unauthenticated attacker can block the single-threaded event loop for many seconds with a small input. No length bound (unlike an HTTP header). Root cause — index.mjs + lib/re.mjs The while ((m = re.exec(text)) !== null) { …testSchemaAt… } scan loop calls the validator at each mailto: hit; srcemailname greedily consumes the whole tail (all chars are in its class) then fails for lack of @. http:/https: do NOT blow up — their validator requires the tail to start with //,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v245-v573-v5vm

  2. Revision 1 · created ·

    Published from osv record GHSA-v245-v573-v5vm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59887

Advisory: linkify-it: Quadratic-complexity DoS via the `mailto:` validator scan-loop on attacker text
IDs: CVE-2026-59887, GHSA-v245-v573-v5vm
Record: https://patchnext.com/advisories/cve-2026-59887 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: linkify-it 5.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm linkify-it: affected <= 5.0.1; fixed in 5.0.2

## Suggested inspection (read-only)
- `npm ls linkify-it --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on linkify-it.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v245-v573-v5vm (OSV record GHSA-v245-v573-v5vm lists affected ranges: npm linkify-it >=0 <5.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-v245-v573-v5vm (GitHub-reviewed advisory GHSA-v245-v573-v5vm lists affected ranges: npm linkify-it >=0 <=5.0.1)

Commands are suggestions: review each one before running it.

Loading voting…