Skip to content

← Actionable
High, CVSS 7.5amended

pyasn1: Quadratic complexity in OBJECT IDENTIFIER and RELATIVE-OID processing allows denial of service

CVE-2026-59885GHSA-8ppf-4f7h-5ppj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyasn1 0.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyasn1

    Affected
    <= 0.6.3
    Fixed in
    0.6.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-59885: 0.62% estimated exploitation activity in the next 30 days; percentile 49.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The BER/CER/DER decoders process OBJECT IDENTIFIER and RELATIVE-OID values in quadratic time relative to the number of arcs. A small crafted payload (tens of kilobytes) containing an OID with many arcs consumes seconds of CPU per decode() call, allowing denial of service in any application that decodes untrusted ASN.1 data (certificates, LDAP, SNMP, Kerberos, etc.). The corresponding encoders have the same quadratic behavior, reachable when an application re-encodes previously decoded attacker-supplied values. The arc-size limit introduced for CVE-2026-23490 bounds the byte length of an individual arc but not the number of arcs, so it does not mitigate this issue. Affected components ObjectIdentifierPayloadDecoder and RelativeOIDPayloadDecoder in pyasn1/codec/ber/decoder.py; ObjectIdentifierEncoder and RelativeOIDEncoder in pyasn1/codec/ber/encoder.py. The CER and DER codecs inherit these and are equally affected. Patches Fixed in pyasn1 0.6.4: arc accumulation in both…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8ppf-4f7h-5ppj

  2. Revision 1 · created ·

    Published from osv record GHSA-8ppf-4f7h-5ppj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59885

Advisory: pyasn1: Quadratic complexity in OBJECT IDENTIFIER and RELATIVE-OID processing allows denial of service
IDs: CVE-2026-59885, GHSA-8ppf-4f7h-5ppj
Record: https://patchnext.com/advisories/cve-2026-59885 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyasn1 0.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyasn1: affected <= 0.6.3; fixed in 0.6.4

## Suggested inspection (read-only)
- `python -m pip show pyasn1`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyasn1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8ppf-4f7h-5ppj (OSV record GHSA-8ppf-4f7h-5ppj lists affected ranges: PyPI pyasn1 >=0 <0.6.4 (fixed))
- Verified: https://github.com/advisories/GHSA-8ppf-4f7h-5ppj (GitHub-reviewed advisory GHSA-8ppf-4f7h-5ppj lists affected ranges: PyPI pyasn1 >=0 <=0.6.3)

Commands are suggestions: review each one before running it.

Loading voting…