Skip to content

← Actionable
High, CVSS 7.5amended

pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs

CVE-2026-59884GHSA-m4p7-r5rc-7g4j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyasn1 0.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyasn1

    Affected
    < 0.6.4
    Fixed in
    0.6.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-59884: 0.62% estimated exploitation activity in the next 30 days; percentile 49.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The BER decoder (shared by the CER and DER codecs) parses long-form tags by accumulating continuation octets in a loop with no upper bound on the size of the tag ID. A crafted input can force the decoder to build an arbitrarily large integer, with CPU cost growing quadratically in input size — a ~1 MB input consumes over a minute of CPU. On Python 3.11+, the oversized tag ID can also trigger an unhandled ValueError (integer string conversion limit) while the decoder formats error messages, violating the documented PyAsn1Error contract and potentially bypassing caller error handling. Any application decoding untrusted BER/CER/DER input is affected. Affected components - pyasn1.codec.ber.decoder — decode() and StreamingDecoder - pyasn1.codec.cer.decoder and pyasn1.codec.der.decoder, which inherit the same tag parsing - pyasn1.type.tag — Tag/TagSet reprs could raise ValueError when rendering oversized tag IDs (reachable through decoder error paths) The encoders and the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m4p7-r5rc-7g4j

  2. Revision 1 · created ·

    Published from osv record GHSA-m4p7-r5rc-7g4j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59884

Advisory: pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs
IDs: CVE-2026-59884, GHSA-m4p7-r5rc-7g4j
Record: https://patchnext.com/advisories/cve-2026-59884 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyasn1 0.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyasn1: affected < 0.6.4; fixed in 0.6.4

## Suggested inspection (read-only)
- `python -m pip show pyasn1`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyasn1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m4p7-r5rc-7g4j (OSV record GHSA-m4p7-r5rc-7g4j lists affected ranges: PyPI pyasn1 >=0 <0.6.4 (fixed))
- Verified: https://github.com/advisories/GHSA-m4p7-r5rc-7g4j (GitHub-reviewed advisory GHSA-m4p7-r5rc-7g4j lists affected ranges: PyPI pyasn1 >=0 <0.6.4)

Commands are suggestions: review each one before running it.

Loading voting…