Skip to content

← Actionable
Medium, CVSS 4.2

guzzlehttp/psr7: Host Confusion via Weak URI Host Validation

CVE-2026-59882GHSA-c2w2-prh8-qm98

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (guzzlehttp/psr7 2.12.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-59882: 0.32% estimated exploitation activity in the next 30 days; percentile 24.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact guzzlehttp/psr7 did not reject URI host components containing authority delimiters (/, ?, #, @, or \), an embedded port such as host:8080, or IPv6 brackets that do not frame the host (such as [::1 or ::1]). Uri::assertValidHost() rejected only control characters, so these malformed hosts were accepted both when parsing a URI string — including through new Uri(), an absolute-form request target passed to Message::parseRequest(), and the synthetic SERVERNAME or SERVERADDR fallback used by ServerRequest::fromGlobals() — and when setting a host with Uri::withHost(). Because the stored host was not validated, Uri::getHost() could return a value that does not agree with the URI's authority or with the host that is actually used on the wire. For example, Uri::withHost('good.com@evil.com') is accepted, and new Uri('http://[gggg::1]/') produces a getHost() of 'gggg:' while getAuthority() returns '[gggg::1'. You are affected if your application builds a Uri or calls Uri::withHost()…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c2w2-prh8-qm98

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59882

Advisory: guzzlehttp/psr7: Host Confusion via Weak URI Host Validation
IDs: CVE-2026-59882, GHSA-c2w2-prh8-qm98
Record: https://patchnext.com/advisories/cve-2026-59882 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: guzzlehttp/psr7 2.12.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist guzzlehttp/psr7: affected < 2.12.3; fixed in 2.12.3

## Suggested inspection (read-only)
- Packagist guzzlehttp/psr7: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on guzzlehttp/psr7.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c2w2-prh8-qm98 (GitHub-reviewed advisory GHSA-c2w2-prh8-qm98 lists affected ranges: Packagist guzzlehttp/psr7 >=0 <2.12.3)

Commands are suggestions: review each one before running it.

Loading voting…