Skip to content

← Actionable
Critical, CVSS 9.2amended

node-tar: Decompression/parse DoS via unlimited input

CVE-2026-59873GHSA-23hp-3jrh-7fpw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tar 7.5.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm tar

    Affected
    <= 7.5.18
    Fixed in
    7.5.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H · score source
EPSS
  • CVE-2026-59873: 0.58% estimated exploitation activity in the next 30 days; percentile 47.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Decompression/parse DoS via unlimited input vulnerability in node-tar allows an attacker to exhaust server resources (disk space and CPU). Because the library does not enforce hard upper bounds on total decompressed data or entry counts, a small, maliciously crafted "Gzip Bomb" can be used to fill a server's storage and crash services. Details The node-tar library does not enforce a hard upper bound on archive size or the volume of decompressed data processed during extraction. While the maxReadSize option exists, it only controls internal read chunk sizes (default 16MB) and does not limit the total cumulative bytes written to disk. Specifically, in src/extract.ts, the Unpack stream processes entries as they arrive. There is no total-bytes limit, entry-count limit, or decompression ratio guard. An attacker can provide a TAR header claiming a massive file size (e.g., 10GB) and follow it with highly compressible data (like zeros). node-tar will continue to extract and write…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-23hp-3jrh-7fpw

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-23hp-3jrh-7fpw

  4. Revision 1 · created ·

    Published from ghsa record GHSA-23hp-3jrh-7fpw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59873

Advisory: node-tar: Decompression/parse DoS via unlimited input
IDs: CVE-2026-59873, GHSA-23hp-3jrh-7fpw
Record: https://patchnext.com/advisories/cve-2026-59873 (revision 4, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tar 7.5.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tar: affected <= 7.5.18; fixed in 7.5.19

## Suggested inspection (read-only)
- `npm ls tar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-23hp-3jrh-7fpw (GitHub-reviewed advisory GHSA-23hp-3jrh-7fpw lists affected ranges: npm tar >=0 <=7.5.18)
- Verified: https://osv.dev/vulnerability/GHSA-23hp-3jrh-7fpw (OSV record GHSA-23hp-3jrh-7fpw lists affected ranges: npm tar >=0 <7.5.19 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…