Skip to content

← Actionable
Medium, CVSS 5.3amended

node-tar: Process crash via PAX numeric path type confusion

CVE-2026-59871GHSA-w8wr-v893-vjvp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tar 7.5.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm tar

    Affected
    <= 7.5.17
    Fixed in
    7.5.18

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-59871: 0.64% estimated exploitation activity in the next 30 days; percentile 50.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A crafted 2.5KB tar archive crashes any Node.js process that extracts it. The PAX header parser coerces all-digit path values to JavaScript numbers, which causes an uncaught TypeError when downstream code calls .split('/') on the numeric value. Error handlers and strict: false cannot intercept the crash. Details In pax.ts line 180, parseKV converts PAX values matching /^[0-9]+$/ to numbers via +v. This applies to all fields including path and linkpath. When a PAX header sets path to an all-digit string like "12345", the value becomes the number 12345. This number flows through Header - ReadEntry - Unpack.CHECKPATH, where normalizeWindowsPath(entry.path).split('/') throws a TypeError because numbers don't have .split(). The throw is synchronous during event emission and bypasses all error handling: - strict: false does not help - 'error' event handlers do not catch it - 'warn' handlers do not catch it - The TypeError propagates through the event emitter stack as an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w8wr-v893-vjvp

  2. Revision 1 · created ·

    Published from osv record GHSA-w8wr-v893-vjvp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59871

Advisory: node-tar: Process crash via PAX numeric path type confusion
IDs: CVE-2026-59871, GHSA-w8wr-v893-vjvp
Record: https://patchnext.com/advisories/cve-2026-59871 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tar 7.5.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tar: affected <= 7.5.17; fixed in 7.5.18

## Suggested inspection (read-only)
- `npm ls tar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w8wr-v893-vjvp (OSV record GHSA-w8wr-v893-vjvp lists affected ranges: npm tar >=0 <7.5.18 (fixed))
- Verified: https://github.com/advisories/GHSA-w8wr-v893-vjvp (GitHub-reviewed advisory GHSA-w8wr-v893-vjvp lists affected ranges: npm tar >=0 <=7.5.17)

Commands are suggestions: review each one before running it.

Loading voting…