js-yaml: Quadratic-complexity (O(n^2)) DoS via !!omap tag in YAML11_SCHEMA
CVE-2026-59870GHSA-724g-mxrg-4qvm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (js-yaml 5.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm js-yaml
- Affected
- >= 5.0.0, <= 5.2.0
- Fixed in
- 5.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-724g-mxrg-4qvm lists affected ranges: npm js-yaml >=5.0.0 <5.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-724g-mxrg-4qvm lists affected ranges: npm js-yaml >=5.0.0 <=5.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-59870: 0.74% estimated exploitation activity in the next 30 days; percentile 54.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary js-yaml v5.x introduces YAML11SCHEMA support with the !!omap (ordered map) tag. The omapTag.addItem() function performs a linear O(n) scan for duplicate key detection on every insertion, resulting in O(n^2) total time to parse a document with n omap entries. An attacker can send a small crafted YAML document to trigger a multi-second CPU stall in any application that uses yaml.load() with { schema: yaml.YAML11SCHEMA }. Details In src/tag/sequence/omap.ts (compiled: dist/js-yaml.cjs.js:510-525): For a document with n unique entries, insertion i scans i−1 existing entries, yielding 1+2+…+n = O(n²) total work. PoC (runtime-confirmed on v5.2.0) Impact Any application that parses untrusted YAML using yaml.load(input, { schema: yaml.YAML11SCHEMA }) is vulnerable to Denial of Service. A ~2 MB payload of 50,000 entries blocks the Node.js event loop for 10+ seconds. Smaller payloads (5,000 entries, ~100 KB) already cause noticeable slowdowns (73 ms per parse, amplified under…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-724g-mxrg-4qvm
- Revision 1 · created ·
Published from osv record GHSA-724g-mxrg-4qvm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59870 Advisory: js-yaml: Quadratic-complexity (O(n^2)) DoS via !!omap tag in YAML11_SCHEMA IDs: CVE-2026-59870, GHSA-724g-mxrg-4qvm Record: https://patchnext.com/advisories/cve-2026-59870 (revision 2, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: js-yaml 5.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm js-yaml: affected >= 5.0.0, <= 5.2.0; fixed in 5.2.1 ## Suggested inspection (read-only) - `npm ls js-yaml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on js-yaml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-724g-mxrg-4qvm (OSV record GHSA-724g-mxrg-4qvm lists affected ranges: npm js-yaml >=5.0.0 <5.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-724g-mxrg-4qvm (GitHub-reviewed advisory GHSA-724g-mxrg-4qvm lists affected ranges: npm js-yaml >=5.0.0 <=5.2.0) Commands are suggestions: review each one before running it.
Loading voting…