Skip to content

← Actionable
Critical, CVSS 9.3

Microsoft Kiota: Command injection via x-ms-kiota-info dependencyInstallCommand surfaced by kiota info

CVE-2026-59865GHSA-hq9q-27g5-qwpj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.openapi.kiota 1.32.5, 1.29.1; microsoft.openapi.kiota.builder 1.32.5, 1.29.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-59865: 4.36% estimated exploitation activity in the next 30 days; percentile 91.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary kiota info — the command developers run to learn which packages to install after generating a client — read the x-ms-kiota-info extension from the OpenAPI description and presented the spec-supplied dependencyInstallCommand (and dependency name/version) as the tool's own recommended install command, replacing kiota's normally-trusted suggestion. With an attacker-controlled or compromised description: A developer who followed kiota's explicit instruction (run the suggested install command) executed attacker-controlled shell — command injection → RCE. The IDE-facing kiota info --json output, which the Kiota VS Code extension consumes to offer/run dependency installation, exposed the raw command string directly, so an "install dependencies" action in the IDE could run it automatically. Confirmed on Kiota 1.32.4. Details x-ms-kiota-info.languagesInformation.<language.dependencyInstallCommand was emitted verbatim as the install-command example, and dependencies[].name/version were…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hq9q-27g5-qwpj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59865

Advisory: Microsoft Kiota: Command injection via x-ms-kiota-info dependencyInstallCommand surfaced by `kiota info`
IDs: CVE-2026-59865, GHSA-hq9q-27g5-qwpj
Record: https://patchnext.com/advisories/cve-2026-59865 (revision 1, source checked 26 Oct 2026, 17:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: microsoft.openapi.kiota 1.32.5, 1.29.1; microsoft.openapi.kiota.builder 1.32.5, 1.29.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet microsoft.openapi.kiota: affected >= 1.30.0, < 1.32.5; < 1.29.1; fixed in 1.29.1, 1.32.5
- NuGet microsoft.openapi.kiota.builder: affected >= 1.30.0, < 1.32.5; < 1.29.1; fixed in 1.29.1, 1.32.5

## Suggested inspection (read-only)
- NuGet microsoft.openapi.kiota: check the installed version with your package manager.
- NuGet microsoft.openapi.kiota.builder: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on microsoft.openapi.kiota, microsoft.openapi.kiota.builder.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hq9q-27g5-qwpj (GitHub-reviewed advisory GHSA-hq9q-27g5-qwpj lists affected ranges: NuGet microsoft.openapi.kiota >=1.30.0 =0 =1.30.0 =0 <1.29.1)

Commands are suggestions: review each one before running it.

Loading voting…