Skip to content

← Actionable
Medium, CVSS 5.3amended

LiteLLM Proxy has server-side request forgery via the user_config request parameter

CVE-2026-59823GHSA-hx8v-g79f-8w5f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.83.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI litellm

    Affected
    <= 1.83.8
    Fixed in
    1.83.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2026-59823: 0.44% estimated exploitation activity in the next 30 days; percentile 38.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A server-side request forgery in LiteLLM Proxy lets an authenticated caller redirect the proxy's outbound request to a host of their choosing by smuggling an apibase inside the userconfig request body, bypassing the existing parameter guard. Details LiteLLM Proxy validates request bodies with isrequestbodysafe, which blocks the apibase and baseurl parameters but does not cover userconfig. The userconfig object is used to build the outbound router for a request, so a caller can place an apibase inside it and reach an arbitrary host. The guard only inspected the two top-level keys, so the same apibase nested inside userconfig was never checked. Exploitation requires a valid virtual key. Impact An authenticated caller can make the proxy issue server-side requests to internal or external hosts of their choosing, reaching endpoints the caller cannot otherwise access. Affected / Patched Affected: <= 1.83.8 Patched: 1.83.9 Remediation Upgrade to 1.83.9 or later (released 2026-04-17).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-hx8v-g79f-8w5f

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-hx8v-g79f-8w5f

  4. Revision 1 · created ·

    Published from ghsa record GHSA-hx8v-g79f-8w5f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59823

Advisory: LiteLLM Proxy has server-side request forgery via the `user_config` request parameter
IDs: CVE-2026-59823, GHSA-hx8v-g79f-8w5f
Record: https://patchnext.com/advisories/cve-2026-59823 (revision 4, source checked 26 Oct 2026, 13:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: litellm 1.83.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI litellm: affected <= 1.83.8; fixed in 1.83.9

## Suggested inspection (read-only)
- `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on litellm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hx8v-g79f-8w5f (GitHub-reviewed advisory GHSA-hx8v-g79f-8w5f lists affected ranges: PyPI litellm >=0 <=1.83.8)
- Verified: https://osv.dev/vulnerability/GHSA-hx8v-g79f-8w5f (OSV record GHSA-hx8v-g79f-8w5f lists affected ranges: PyPI litellm >=0 <1.83.9 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…