LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback
CVE-2026-59822GHSA-7488-6r32-c95q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.84.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litellm
- Affected
- < 1.84.0
- Fixed in
- 1.84.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7488-6r32-c95q lists affected ranges: PyPI litellm >=0 <1.84.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2026-59822 to the Known Exploited Vulnerabilities catalog on 2026-09-02.
VerifiedObserved Listed in the CISA KEV JSON feed; separate from customer applicability.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2026-59822 to the Known Exploited Vulnerabilities catalog on 2026-09-02.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2026-09-02).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7488-6r32-c95q lists affected ranges: PyPI litellm >=0 <1.84.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-59822: 0.84% estimated exploitation activity in the next 30 days; percentile 57.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact LiteLLM's MCP Streamable HTTP endpoint could allow an unauthenticated attacker to establish an authenticated MCP session using an arbitrary Bearer token. The MCP auth handler supported OAuth2 passthrough for upstream MCP servers, but the fallback path could replace failed LiteLLM key validation with an empty UserAPIKeyAuth() object. This allowed requests with a fabricated Authorization header to reach MCP tooling without a valid LiteLLM key. An attacker could use this to list and call configured MCP tools and access connected services exposed through MCP. Patches The issue is fixed in 1.84.0. We recommend upgrading to 1.84.0 or later. Workarounds If upgrading is not immediately possible, disable MCP routes or block access to /mcp/ and related MCP endpoints at your reverse proxy or API gateway. References v1.84.0
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-7488-6r32-c95q
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · evidence added ·
CISA KEV confirmed exploitation for CVE-2026-59822 (date added 2026-09-02). Customer workflow unchanged.
- Revision 1 · created ·
Published from osv record GHSA-7488-6r32-c95q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59822 Advisory: LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback IDs: CVE-2026-59822, GHSA-7488-6r32-c95q Record: https://patchnext.com/advisories/cve-2026-59822 (revision 4, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: litellm 1.84.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litellm: affected < 1.84.0; fixed in 1.84.0 ## Suggested inspection (read-only) - `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litellm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7488-6r32-c95q (OSV record GHSA-7488-6r32-c95q lists affected ranges: PyPI litellm >=0 <1.84.0 (fixed)) - Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2026-59822 to the Known Exploited Vulnerabilities catalog on 2026-09-02.) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2026-59822 to the Known Exploited Vulnerabilities catalog on 2026-09-02.) - Verified: https://github.com/advisories/GHSA-7488-6r32-c95q (GitHub-reviewed advisory GHSA-7488-6r32-c95q lists affected ranges: PyPI litellm >=0 <1.84.0) Commands are suggestions: review each one before running it.
Loading voting…