LiteLLM: Custom Code Guardrails production endpoints bypass code safety checks
CVE-2026-59821GHSA-72m8-9m7m-h278
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.82.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litellm
- Affected
- < 1.82.0
- Fixed in
- 1.82.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-72m8-9m7m-h278 lists affected ranges: PyPI litellm >=0 <1.82.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-72m8-9m7m-h278 lists affected ranges: PyPI litellm >=0 <1.82.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-59821: 0.90% estimated exploitation activity in the next 30 days; percentile 59.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact LiteLLM's Custom Code Guardrails production create/update paths did not apply the same sandboxing and validation used by the test endpoint. A privileged user with access to create or update guardrails could submit custom Python code that executed in the LiteLLM proxy environment. In deployments without a configured master key, callers could be treated as proxy administrators, making this reachable without intended administrative authorization. This could allow arbitrary code execution in the LiteLLM proxy container and exposure of secrets available to the process. Patches The issue is fixed in 1.82.0-stable. LiteLLM recommend upgrading to 1.82.0-stable or later. Workarounds If upgrading is not immediately possible: 1. Restrict access to POST /guardrails and PUT /guardrails/{guardrailid} to trusted administrators only. 2. Ensure LITELLMMASTERKEY is configured. 3. Avoid enabling Custom Code Guardrails for untrusted users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-72m8-9m7m-h278
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-72m8-9m7m-h278
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59821 Advisory: LiteLLM: Custom Code Guardrails production endpoints bypass code safety checks IDs: CVE-2026-59821, GHSA-72m8-9m7m-h278 Record: https://patchnext.com/advisories/cve-2026-59821 (revision 3, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: litellm 1.82.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litellm: affected < 1.82.0; fixed in 1.82.0 ## Suggested inspection (read-only) - `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litellm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-72m8-9m7m-h278 (OSV record GHSA-72m8-9m7m-h278 lists affected ranges: PyPI litellm >=0 <1.82.0 (fixed)) - Verified: https://github.com/advisories/GHSA-72m8-9m7m-h278 (GitHub-reviewed advisory GHSA-72m8-9m7m-h278 lists affected ranges: PyPI litellm >=0 <1.82.0) Commands are suggestions: review each one before running it.
Loading voting…